summaryrefslogtreecommitdiff
path: root/media-libs/opencolorio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
commit5b5df25227111ef465caf5c52bcfb66dac3219cd (patch)
tree31b713cac6188358125cbb66b8804030328740f0 /media-libs/opencolorio/files
parent02e2208f46f4e2c00fb9743cbc47350bdd233bfa (diff)
gentoo resync : 19.01.2018
Diffstat (limited to 'media-libs/opencolorio/files')
-rw-r--r--media-libs/opencolorio/files/opencolorio-1.1.0-fix-compile-error-with-Lut1DOp.cpp.patch92
-rw-r--r--media-libs/opencolorio/files/opencolorio-1.1.0-remove-building-of-bundled-programs.patch (renamed from media-libs/opencolorio/files/opencolorio-1.1.0-cmake-fixes.patch)87
-rw-r--r--media-libs/opencolorio/files/opencolorio-1.1.0-use-GNUInstallDirs-and-fix-cmake-install-location.patch102
3 files changed, 228 insertions, 53 deletions
diff --git a/media-libs/opencolorio/files/opencolorio-1.1.0-fix-compile-error-with-Lut1DOp.cpp.patch b/media-libs/opencolorio/files/opencolorio-1.1.0-fix-compile-error-with-Lut1DOp.cpp.patch
new file mode 100644
index 000000000000..b5455d010b42
--- /dev/null
+++ b/media-libs/opencolorio/files/opencolorio-1.1.0-fix-compile-error-with-Lut1DOp.cpp.patch
@@ -0,0 +1,92 @@
+From 8d38317f68d0e4663abbccdceca0bcd41f3dcf4a Mon Sep 17 00:00:00 2001
+From: Patrick Hodoul <patrick.hodoul@autodesk.com>
+Date: Mon, 27 Nov 2017 17:29:57 -0500
+Subject: [PATCH 1/3] Fix compile error with Lut1DOp.cpp
+
+Fix Linux compilation
+Fix gcc 5.4.0 build breaks
+Fix the temp filename for Linux
+---
+ src/core/Lut1DOp.cpp | 4 +++-
+ src/core/MathUtils.cpp | 23 ++++++++++++-----------
+ src/pyglue/PyAllocationTransform.cpp | 1 -
+ 3 files changed, 15 insertions(+), 13 deletions(-)
+
+diff --git a/src/core/Lut1DOp.cpp b/src/core/Lut1DOp.cpp
+index 404ee0b..180e30f 100644
+--- a/src/core/Lut1DOp.cpp
++++ b/src/core/Lut1DOp.cpp
+@@ -188,7 +188,8 @@ OCIO_NAMESPACE_ENTER
+ {
+ return simple_lut[clamp(index, 0.0f, maxIndex)];
+ }
+-
++
++#if defined(OCIO_UNIT_TEST) || !defined(USE_SSE)
+ void Lut1D_Nearest(float* rgbaBuffer, long numPixels, const Lut1D & lut)
+ {
+ float maxIndex[3];
+@@ -218,6 +219,7 @@ OCIO_NAMESPACE_ENTER
+ rgbaBuffer += 4;
+ }
+ }
++#endif
+ #ifdef USE_SSE
+ void Lut1D_Nearest_SSE(float* rgbaBuffer, long numPixels, const Lut1D & lut)
+ {
+diff --git a/src/core/MathUtils.cpp b/src/core/MathUtils.cpp
+index e1a26c0..3881eb3 100644
+--- a/src/core/MathUtils.cpp
++++ b/src/core/MathUtils.cpp
+@@ -327,17 +327,6 @@ OCIO_NAMESPACE_ENTER
+ GetV4Sum(vout, vout, v2);
+ }
+
+- namespace
+- {
+-
+- void GetMxbResult(float* vout, float* m, float* x, float* v)
+- {
+- GetM44V4Product(vout, m, x);
+- GetV4Sum(vout, vout, v);
+- }
+-
+- } // anon namespace
+-
+ bool GetMxbInverse(float* mout, float* vout,
+ const float* m_, const float* v_)
+ {
+@@ -372,6 +361,18 @@ OCIO_NAMESPACE_USING
+
+ #include "UnitTest.h"
+
++namespace
++{
++
++ void GetMxbResult(float* vout, float* m, float* x, float* v)
++ {
++ GetM44V4Product(vout, m, x);
++ GetV4Sum(vout, vout, v);
++ }
++
++}
++
++
+ OIIO_ADD_TEST(MathUtils, M44_is_diagonal)
+ {
+ {
+diff --git a/src/pyglue/PyAllocationTransform.cpp b/src/pyglue/PyAllocationTransform.cpp
+index 20bb50e..06b418a 100644
+--- a/src/pyglue/PyAllocationTransform.cpp
++++ b/src/pyglue/PyAllocationTransform.cpp
+@@ -53,7 +53,6 @@ OCIO_NAMESPACE_ENTER
+ ///
+
+ int PyOCIO_AllocationTransform_init(PyOCIO_Transform * self, PyObject * args, PyObject * kwds);
+- PyObject * PyOCIO_AllocationTransform_equals(PyObject * self, PyObject * args);
+ PyObject * PyOCIO_AllocationTransform_getAllocation(PyObject * self);
+ PyObject * PyOCIO_AllocationTransform_setAllocation(PyObject * self, PyObject * args);
+ PyObject * PyOCIO_AllocationTransform_getNumVars(PyObject * self);
+--
+2.15.1
+
diff --git a/media-libs/opencolorio/files/opencolorio-1.1.0-cmake-fixes.patch b/media-libs/opencolorio/files/opencolorio-1.1.0-remove-building-of-bundled-programs.patch
index 9cb3500d9dab..9041677c9ce4 100644
--- a/media-libs/opencolorio/files/opencolorio-1.1.0-cmake-fixes.patch
+++ b/media-libs/opencolorio/files/opencolorio-1.1.0-remove-building-of-bundled-programs.patch
@@ -1,35 +1,19 @@
-diff -purN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2017-11-29 22:51:15.000000000 +0000
-+++ b/CMakeLists.txt 2017-12-27 16:49:51.461300828 +0000
-@@ -59,6 +59,7 @@ endif()
- include(ParseArguments)
- include(OCIOMacros)
- include(ExternalProject)
-+include(GNUInstallDirs)
+From 967369b36c9684d7ffb73a926c442d8991a3afef Mon Sep 17 00:00:00 2001
+From: Jonathan Scruggs <j.scruggs@gmail.com>
+Date: Mon, 15 Jan 2018 13:09:31 +0000
+Subject: [PATCH 3/3] Remove building of bundled programs
+
+---
+ docs/CMakeLists.txt | 98 ++---------------------------------------------------
+ 1 file changed, 3 insertions(+), 95 deletions(-)
+
+diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
+index a822a19..d588139 100644
+--- a/docs/CMakeLists.txt
++++ b/docs/CMakeLists.txt
+@@ -1,90 +1,4 @@
- enable_language(CXX)
-
-@@ -531,7 +532,7 @@ endif()
- configure_file(${CMAKE_SOURCE_DIR}/share/ocio/setup_ocio.sh.in
- ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh @ONLY)
-
--INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION share/ocio/)
-+INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/ocio/)
-
- ###############################################################################
- ### CPACK ###
-@@ -646,4 +647,4 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColo
- message(STATUS OPENCOLORIO_FOUND=\${OPENCOLORIO_FOUND})
- "
- )
--install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION .)
-+install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION ${CMAKE_INSTALL_LIBDIR}/CMake)
-diff -purN a/docs/CMakeLists.txt b/docs/CMakeLists.txt
---- a/docs/CMakeLists.txt 2017-11-29 22:51:15.000000000 +0000
-+++ b/docs/CMakeLists.txt 2017-12-27 16:53:28.976491353 +0000
-@@ -1,91 +1,5 @@
-
- ###############################################################################
+-###############################################################################
-### External Doc Apps ###
-
-if (WIN32)
@@ -115,10 +99,9 @@ diff -purN a/docs/CMakeLists.txt b/docs/CMakeLists.txt
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/Sphinx-prefix/src/Sphinx
-)
-
--###############################################################################
+ ###############################################################################
### Create Doc Targets ###
- message(STATUS "Create sphinx conf.py from conf.py.in")
@@ -122,7 +36,7 @@ else()
endif()
@@ -128,32 +111,30 @@ diff -purN a/docs/CMakeLists.txt b/docs/CMakeLists.txt
DEPENDS
${DEPLIBS}
${CMAKE_BINARY_DIR}/docs/conf.py
-@@ -133,20 +47,18 @@ add_custom_target(doc ALL
+@@ -131,11 +45,7 @@ add_custom_target(doc ALL
+ developers/api/OpenColorTypes.rst
+ ${RSTDOC_OUTPUT}
COMMENT "Building html docs"
SOURCES ${DOCFILES})
-
+-
-# note: ExternalProject will not build when added to a add_custom_target this
-# works around this problem. This seems to be fixed in the cmake ^HEAD
-add_dependencies(doc Sphinx)
--
- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build-html/
-- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/OpenColorIO/html
-+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/html
- PATTERN .* EXCLUDE
- )
-+if(OCIO_BUILD_PDF_DOCS)
-+
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build-html/
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}/html
+@@ -146,8 +56,8 @@ find_package(LATEX)
find_package(LATEX)
if(PDFLATEX_COMPILER)
- add_custom_target(latex
+- add_custom_target(latex
- COMMAND ${PYT_PRE_CMD} ${EXTDIST_BINPATH}/sphinx-build -b latex . ${CMAKE_CURRENT_BINARY_DIR}/build-latex
++ add_custom_target(latex ALL
+ COMMAND sphinx-build -b latex . ${CMAKE_CURRENT_BINARY_DIR}/build-latex
DEPENDS
OpenColorIO
${CMAKE_BINARY_DIR}/docs/conf.py
-@@ -156,7 +68,6 @@ if(PDFLATEX_COMPILER)
+@@ -156,14 +66,12 @@ if(PDFLATEX_COMPILER)
${RSTDOC_OUTPUT}
COMMENT "Building latex doc"
SOURCES ${DOCFILES})
@@ -161,13 +142,13 @@ diff -purN a/docs/CMakeLists.txt b/docs/CMakeLists.txt
add_custom_target(pdf ALL
COMMAND ${PDFLATEX_COMPILER} OpenColorIO.tex
-@@ -166,6 +77,8 @@ if(PDFLATEX_COMPILER)
- add_dependencies(pdf latex)
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build-latex
+ COMMENT "Building pdf doc"
+ SOURCES ${DOCFILES})
+- add_dependencies(pdf latex)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/build-latex/OpenColorIO.pdf
-- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/OpenColorIO/)
-+ DESTINATION ${CMAKE_INSTALL_DOCDIR})
-
- endif()
-+
-+endif()
+ DESTINATION ${CMAKE_INSTALL_DOCDIR})
+--
+2.15.1
+
diff --git a/media-libs/opencolorio/files/opencolorio-1.1.0-use-GNUInstallDirs-and-fix-cmake-install-location.patch b/media-libs/opencolorio/files/opencolorio-1.1.0-use-GNUInstallDirs-and-fix-cmake-install-location.patch
new file mode 100644
index 000000000000..e4c6296f1d7f
--- /dev/null
+++ b/media-libs/opencolorio/files/opencolorio-1.1.0-use-GNUInstallDirs-and-fix-cmake-install-location.patch
@@ -0,0 +1,102 @@
+From c43cc918c3e79e324f11ca47e95bfe36e9e0dd15 Mon Sep 17 00:00:00 2001
+From: Jonathan Scruggs <j.scruggs@gmail.com>
+Date: Sun, 14 Jan 2018 19:59:31 +0000
+Subject: [PATCH] Add GNUInstallDirs variables and fix install location for
+ cmake files
+
+GNUInstallDirs is supported on all platforms and variables are set
+to the standard GNU locations.
+
+This patch corrects the location where the CMake files are
+installed.
+
+Signed-off by: Jonathan Scruggs <j.scruggs@gmail.com>
+---
+ CMakeLists.txt | 9 +++++----
+ docs/CMakeLists.txt | 4 ++--
+ export/pkgconfig/OpenColorIO.pc.in | 6 ++----
+ 3 files changed, 9 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b05c7e4..452fa1e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -59,6 +59,7 @@ endif()
+ include(ParseArguments)
+ include(OCIOMacros)
+ include(ExternalProject)
++include(GNUInstallDirs)
+
+ enable_language(CXX)
+
+@@ -531,7 +532,7 @@ endif()
+ configure_file(${CMAKE_SOURCE_DIR}/share/ocio/setup_ocio.sh.in
+ ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh @ONLY)
+
+-INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION share/ocio/)
++INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/share/ocio/setup_ocio.sh DESTINATION ${CMAKE_INSTALL_DATADIR}/ocio/)
+
+ ###############################################################################
+ ### CPACK ###
+@@ -596,7 +597,7 @@ if(TARGET OpenColorIO_STATIC)
+ set(OCIO_STATIC_COMPILE_DEFINITIONS )
+ endif()
+ endif()
+-install(EXPORT OpenColorIO DESTINATION cmake)
++install(EXPORT OpenColorIO DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenColorIO)
+ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
+ "
+ get_filename_component(OpenColorIO_DIR \"\${CMAKE_CURRENT_LIST_FILE}\" PATH)
+@@ -608,7 +609,7 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
+
+ ## targets libraries + associated definitions
+ if(NOT TARGET OpenColorIO)
+- include(\"\${OpenColorIO_DIR}/cmake/OpenColorIO.cmake\") ## thanks to imported target
++ include(\"\${OpenColorIO_DIR}/${CMAKE_INSTALL_LIBDIR}/cmake/OpenColorIO/OpenColorIO.cmake\") ## thanks to imported target
+ if(TARGET OpenColorIO AND NOT OpenColorIO_USE_STATIC)
+ message(STATUS \"shared target OpenColorIO : see OpenColorIO_LIBRARY\")
+ set(OpenColorIO_LIBRARY OpenColorIO)
+@@ -646,4 +647,4 @@ file(WRITE "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake"
+ message(STATUS OPENCOLORIO_FOUND=\${OPENCOLORIO_FOUND})
+ "
+ )
+-install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION .)
++install(FILES "${CMAKE_BINARY_DIR}/OpenColorIOConfig.cmake" DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenColorIO)
+diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
+index 3fd0299..a822a19 100644
+--- a/docs/CMakeLists.txt
++++ b/docs/CMakeLists.txt
+@@ -138,7 +138,7 @@ add_custom_target(doc ALL
+ add_dependencies(doc Sphinx)
+
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build-html/
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/OpenColorIO/html
++ DESTINATION ${CMAKE_INSTALL_DOCDIR}/html
+ PATTERN .* EXCLUDE
+ )
+
+@@ -166,6 +166,6 @@ if(PDFLATEX_COMPILER)
+ add_dependencies(pdf latex)
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/build-latex/OpenColorIO.pdf
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/OpenColorIO/)
++ DESTINATION ${CMAKE_INSTALL_DOCDIR})
+
+ endif()
+diff --git a/export/pkgconfig/OpenColorIO.pc.in b/export/pkgconfig/OpenColorIO.pc.in
+index 81ab4ce3..c4553a4f 100644
+--- a/export/pkgconfig/OpenColorIO.pc.in
++++ b/export/pkgconfig/OpenColorIO.pc.in
+@@ -1,7 +1,5 @@
+-prefix=@CMAKE_INSTALL_PREFIX@
+-exec_prefix=@CMAKE_INSTALL_EXEC_PREFIX@
+-includedir=${prefix}/include
+-libdir=${exec_prefix}/lib@LIB_SUFFIX@
++libdir=@CMAKE_INSTALL_FULL_LIBDIR@
++includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
+
+ Name: OpenColorIO
+ Description: A color management framework for visual effects and animation
+--
+2.15.1
+