summaryrefslogtreecommitdiff
path: root/media-libs/opencv/opencv-4.5.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /media-libs/opencv/opencv-4.5.2-r3.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'media-libs/opencv/opencv-4.5.2-r3.ebuild')
-rw-r--r--media-libs/opencv/opencv-4.5.2-r3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-libs/opencv/opencv-4.5.2-r3.ebuild b/media-libs/opencv/opencv-4.5.2-r3.ebuild
index 9b1bb3c11c7c..9b3f36c342d0 100644
--- a/media-libs/opencv/opencv-4.5.2-r3.ebuild
+++ b/media-libs/opencv/opencv-4.5.2-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -295,6 +295,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff