summaryrefslogtreecommitdiff
path: root/media-libs/openexr/openexr-2.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-libs/openexr/openexr-2.5.2-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-libs/openexr/openexr-2.5.2-r1.ebuild')
-rw-r--r--media-libs/openexr/openexr-2.5.2-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-libs/openexr/openexr-2.5.2-r1.ebuild b/media-libs/openexr/openexr-2.5.2-r1.ebuild
deleted file mode 100644
index cd30b0dee54a..000000000000
--- a/media-libs/openexr/openexr-2.5.2-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib flag-o-matic toolchain-funcs
-
-DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
-HOMEPAGE="https://www.openexr.com/"
-SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/25" # based on SONAME
-KEYWORDS="amd64 ~arm arm64 hppa ~ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-IUSE="cpu_flags_x86_avx doc examples static-libs utils test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- media-libs/ilmbase:=[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${P}/OpenEXR"
-
-DOCS=( PATENTS README.md )
-
-MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/OpenEXRConfigInternal.h )
-
-src_prepare() {
- cmake_src_prepare
-
- # Fix path for testsuite
- sed -i -e "s:/var/tmp/:${T}:" "${S}"/IlmImfTest/tmpDir.h || die "failed to set temp path for tests"
-
- if use abi_x86_32 && use test; then
- eapply "${FILESDIR}/${P}-0001-IlmImfTest-main.cpp-disable-tests.patch"
- fi
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test)
- -DINSTALL_OPENEXR_DOCS=$(usex doc)
- -DINSTALL_OPENEXR_EXAMPLES=$(usex examples)
- -DOPENEXR_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
- -DOPENEXR_BUILD_UTILS=$(usex utils)
- -DOPENEXR_INSTALL_PKG_CONFIG=ON # default
- )
-
- cmake_src_configure
-}
-
-multilib_src_install_all() {
- if use doc; then
- DOCS+=( doc/*.pdf )
- fi
- einstalldocs
-
- use examples && docompress -x /usr/share/doc/${PF}/examples
-}