summaryrefslogtreecommitdiff
path: root/media-libs/sdl-mixer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-01 12:01:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-01 12:01:16 +0100
commit4d37b8aa4c6b04fa417e8f87f276f7e08a411ee0 (patch)
treea53cac2dfa1e2a70dea6c0d6d6e1d7ff3bde743d /media-libs/sdl-mixer
parent5b7f6475da27c05b30659a00ecb49636aca2bece (diff)
gentoo auto-resync : 01:09:2024 - 12:01:15
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/Manifest2
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.12_p20240525.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/media-libs/sdl-mixer/Manifest b/media-libs/sdl-mixer/Manifest
index 95417c42a9b8..cb2bd795d636 100644
--- a/media-libs/sdl-mixer/Manifest
+++ b/media-libs/sdl-mixer/Manifest
@@ -1,3 +1,5 @@
DIST sdl-mixer-1.2.12_p20221010.tar.gz 5861748 BLAKE2B 95b8e59bf796aa1a1593d8895aa153d62653fc9085e65c380cef3a0394201dd6c5c0deb323d6acecd4bca0e46d11f0ec94ebab8be872654e46d2d56231a1fd12 SHA512 5b15bf81b868968a09f82b160e371355e40a29c95a3e79c3cffa49ab5cc7c3212034d12301c21c8a44aef5c981a7a8fec3cb76e9dfe55619159a613b8dec6557
+DIST sdl-mixer-1.2.12_p20240525.tar.gz 5835402 BLAKE2B 61238592251259c464f4e85be894f8ffcb8259c47bb56cddb0795fa4cd9f3fba2b431680b7a65ac9c2c87153f7e3bdde7b2496f5c536e55764e09c9450cdbea9 SHA512 1925b025c99a47d635f8a9a211712103c641a82c6d4e930b996de4eb1a08d5f5b1892dfd999924e0945d63ae4c59550ac112fbf7f8d76846d6ee54b1434e82a8
EBUILD sdl-mixer-1.2.12_p20221010.ebuild 3108 BLAKE2B 75935929446c71089c2e0debb614e6b80a37b743274fd23062f9290ca196e9649847bf80a70d6243f126969463394edb595a1de1dfa30c902abb2adfb2e51fb5 SHA512 0654c3a6e6c6eed8a3354e58e7976ddd5cc4149ce3681fa21a67c14824ccc03c19b22829f5e90e66a9dc57af874ca1964eb5f0287b0f9360b0c939d5378595b3
+EBUILD sdl-mixer-1.2.12_p20240525.ebuild 3115 BLAKE2B 5a7c24d2f9134a2ec89658bf305f9678d94aa6d6f61e0c451f9e731e42540f28ff4b953e3bd7cea646960c9e8dbd432c9e16b3afd5f141509435a532bb192a17 SHA512 4482bf563584ca0edba981fbe6dd0ad84d00a509f1def04a78540ab488e5a7299fffed9e9605db04dc43eff3262d5bb23d9bbe3f05a657a47551fd3662970970
MISC metadata.xml 787 BLAKE2B 4a9a04b0b88ec853de52f1cc7f6ad63e6bd4e5a421906daa2e0935c32d756538ef9aee8631e5be96665dd37ec6c4e47d256e30b01f7cc6ca56f29baaaa5ef27d SHA512 46520c6a56e9d6ff2137e71bf728349ed167f7ec10417345528e6da051e482b3a27158e46ae973d1bd0f348cac9e3f65e8a02eef984b8e00fbb2aced256ad2bd
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.12_p20240525.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.12_p20240525.ebuild
new file mode 100644
index 000000000000..0fa3a0936e53
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.12_p20240525.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check SDL-1.2 branch for possible backports/new snapshots
+
+inherit multilib-minimal
+
+SDL_MIXER_COMMIT="ed76d39cda0735d26c14a3e4f4da996e420f6478"
+
+MY_PN=${PN/sdl-/SDL_}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="https://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="https://github.com/libsdl-org/SDL_mixer/archive/${SDL_MIXER_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${SDL_MIXER_COMMIT}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 playtools smpeg static-libs timidity vorbis +wav"
+
+REQUIRED_USE="
+ midi? ( || ( timidity fluidsynth ) )
+ timidity? ( midi )
+ fluidsynth? ( midi )
+ mp3? ( || ( smpeg mad ) )
+ smpeg? ( mp3 )
+ mad? ( mp3 )
+ mod? ( || ( mikmod modplug ) )
+ mikmod? ( mod )
+ modplug? ( mod )
+"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.15-r4[${MULTILIB_USEDEP}]
+ flac? ( >=media-libs/flac-1.2.1-r5:=[${MULTILIB_USEDEP}] )
+ midi? (
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.6-r1:=[${MULTILIB_USEDEP}] )
+ timidity? ( media-sound/timidity++ )
+ )
+ mod? (
+ mikmod? ( >=media-libs/libmikmod-3.3.6-r1[${MULTILIB_USEDEP}] )
+ modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
+ )
+ mp3? (
+ mad? ( >=media-libs/libmad-0.15.1b-r8[${MULTILIB_USEDEP}] )
+ smpeg? ( >=media-libs/smpeg-0.4.4-r10[${MULTILIB_USEDEP}] )
+ )
+ vorbis? (
+ >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}]
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-music-flac-shared
+ --disable-music-fluidsynth-shared
+ --disable-music-mod-shared
+ --disable-music-mp3-shared
+ --disable-music-ogg-shared
+
+ $(use_enable wav music-wave)
+ $(use_enable vorbis music-ogg)
+ $(use_enable mikmod music-mod)
+ $(use_enable modplug music-mod-modplug)
+ $(use_enable flac music-flac)
+ $(use_enable static-libs static)
+ $(use_enable smpeg music-mp3)
+ $(use_enable mad music-mp3-mad-gpl)
+ $(use_enable timidity music-timidity-midi)
+ $(use_enable fluidsynth music-fluidsynth-midi)
+
+ LIBMIKMOD_CONFIG="${EPREFIX}"/usr/bin/${CHOST}-libmikmod-config
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use playtools; then
+ emake DESTDIR="${D}" install-bin
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # bug 412035
+ # https://bugs.gentoo.org/show_bug.cgi?id=412035
+ if use midi ; then
+ if use fluidsynth; then
+ ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+ ewarn "environment variable to the location of a SoundFont file"
+ ewarn "unless the game or application happens to do this for you."
+
+ if use timidity; then
+ ewarn "Failing to do so will result in Timidity being used instead."
+ else
+ ewarn "Failing to do so will result in silence."
+ fi
+ fi
+ fi
+}