summaryrefslogtreecommitdiff
path: root/media-libs/skstream/skstream-0.3.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /media-libs/skstream/skstream-0.3.9.ebuild
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'media-libs/skstream/skstream-0.3.9.ebuild')
-rw-r--r--media-libs/skstream/skstream-0.3.9.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/media-libs/skstream/skstream-0.3.9.ebuild b/media-libs/skstream/skstream-0.3.9.ebuild
index 5a64f6452b82..0acc8b73db99 100644
--- a/media-libs/skstream/skstream-0.3.9.ebuild
+++ b/media-libs/skstream/skstream-0.3.9.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit base eutils
+EAPI=6
+
+inherit flag-o-matic
DESCRIPTION="FreeSockets - Portable C++ classes for IP (sockets) applications"
HOMEPAGE="http://www.worldforge.org/"
@@ -17,4 +18,10 @@ DEPEND="test? ( dev-util/cppunit )"
RDEPEND=""
PATCHES=( "${FILESDIR}"/${P}-test.patch )
-DOCS=( AUTHORS ChangeLog NEWS README README.FreeSockets TODO )
+
+src_configure() {
+ # bug 651840
+ append-cxxflags -std=c++11
+
+ default
+}