summaryrefslogtreecommitdiff
path: root/media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch')
-rw-r--r--media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch b/media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch
new file mode 100644
index 000000000000..1983e4bff3b2
--- /dev/null
+++ b/media-libs/speexdsp/files/speexdsp-1.2.0-configure.patch
@@ -0,0 +1,41 @@
+--- speexdsp-1.2.0/configure.ac
++++ speexdsp-1.2.0/configure.ac
+@@ -152,9 +152,17 @@
+ if test "x$enableval" != xno; then
+ has_sse=yes
+ has_sse2=yes
+-CFLAGS="$CFLAGS -O3 -msse -msse2"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
++fi
++])
++
++AC_ARG_ENABLE(sse2, [ --enable-sse2 Enable SSE2 support], [
++if test "x$enableval" != xno; then
++has_sse2=yes
++CFLAGS="$CFLAGS -msse2"
++else
+ has_sse2=no
+ fi
+ ])
+@@ -163,7 +171,7 @@
+ if test "x$enableval" != xno; then
+ has_neon=yes
+ AS_CASE(["$host"],
+- [arm*], [CFLAGS="$CFLAGS -O3 -march=armv7-a -mfpu=neon"]
++ [arm*], [CFLAGS="$CFLAGS -mfpu=neon"]
+ )
+ else
+ has_neon=no
+--- speexdsp-1.2.0/libspeexdsp/Makefile.am
++++ speexdsp-1.2.0/libspeexdsp/Makefile.am
+@@ -29,7 +29,7 @@
+ pseudofloat.h smallft.h vorbis_psy.h resample_sse.h resample_neon.h
+
+ libspeexdsp_la_LDFLAGS = -no-undefined -version-info @SPEEXDSP_LT_CURRENT@:@SPEEXDSP_LT_REVISION@:@SPEEXDSP_LT_AGE@
+-libspeexdsp_la_LIBADD = $(LIBM)
++libspeexdsp_la_LIBADD = $(LIBM) $(FFT_LIBS)
+
+ if BUILD_EXAMPLES
+ noinst_PROGRAMS = testdenoise testecho testjitter testresample testresample2