summaryrefslogtreecommitdiff
path: root/media-libs/x264
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /media-libs/x264
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/Manifest2
-rw-r--r--media-libs/x264/x264-0.0.20190214.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/x264/Manifest b/media-libs/x264/Manifest
index 1d88a8d54708..8da2cb66d613 100644
--- a/media-libs/x264/Manifest
+++ b/media-libs/x264/Manifest
@@ -1,4 +1,6 @@
DIST x264-snapshot-20170701-2245.tar.bz2 750527 BLAKE2B ccf276da31383ab4b4a1ac48866bc49b4b2bc5913361c933fa2359de4d6e90cca091dd4aba781f3735a5b28d6ce006aa9d4e149ba48745b80cb971c2952ca867 SHA512 28fc9850c36ac385fced6dec9a0f68a5605a68805e1ef7b8cedcd78917eaa1ad6e47e57fe5a74fee0a6e482f3a33de6011f675e6c77b5db94c8fe01d5c5f3e9f
+DIST x264-snapshot-20190214-2245.tar.bz2 770462 BLAKE2B d90a3bafb88febe12526b225617616a62c32fa3d3eacf410267e1fbd7e0fafaadca7c146172c08fc525bce8791d81c7d87dc27b06d61a6a44bf2ad92f6c1def6 SHA512 c8b1b46d4e6c0ef653dab35083a454c635ebf72c6a5255ce30bbb5d9d6bb8e23fca0e6cc197ea99f3c702fbfec096587df6fa82dec338d8bd45e35fa89c43039
EBUILD x264-0.0.20170701.ebuild 1908 BLAKE2B 0d707b757a65ca4436f04d5cbdbd11682f61496dfe9e19a73079476452e397928313e1ae030db6cb68d0c8fa857ce925a9b7a9b69846fe6147b659ade30e6469 SHA512 4d6505deffec4108071dbbdb0788a0eb59695703890d168bc641e361af2b6c4d05606b415f0bb8a6dd3e6dd629dd2eb8390d3a2f2847369bf7c5d567dff9b105
+EBUILD x264-0.0.20190214.ebuild 1818 BLAKE2B 2f5792963f71ab0041436d84a2ccfc542ff1b020ec43b5933174ca8d79e5f1d7224658bbd6fff89f5e86e077f1eab771207f932704f4e2dedee41563dd9faffe SHA512 d6523f4a919500361cbf4c8f9530de38d9201a903fc8c3b3fc9dbcda22d571b54568a79a0d95b4e88015f44d95987f10aff5d6105bb94ada96b077ff7b13c641
EBUILD x264-9999.ebuild 1818 BLAKE2B 2f5792963f71ab0041436d84a2ccfc542ff1b020ec43b5933174ca8d79e5f1d7224658bbd6fff89f5e86e077f1eab771207f932704f4e2dedee41563dd9faffe SHA512 d6523f4a919500361cbf4c8f9530de38d9201a903fc8c3b3fc9dbcda22d571b54568a79a0d95b4e88015f44d95987f10aff5d6105bb94ada96b077ff7b13c641
MISC metadata.xml 589 BLAKE2B c7ee19e724c9c449efda7bf1733193d71c547bc3a80efb51d6b562a8d0134bb618d1daad542cc61fc5d0026467a4336ec0754f238e441cad8cfe72296c4eae07 SHA512 7a4acc6f2cf54f66efee1fedb379ea155559ddca1ff8bae88b5a8638b23555515e9cc31dff7ae6bb16e6d716e616dcb4b508870ad78ab1fe461ba8b7056f524e
diff --git a/media-libs/x264/x264-0.0.20190214.ebuild b/media-libs/x264/x264-0.0.20190214.ebuild
new file mode 100644
index 000000000000..0128bcd158b6
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20190214.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="https://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.videolan.org/git/x264.git"
+else
+ MY_P="x264-snapshot-$(ver_cut 3)-2245"
+ SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+SLOT="0/157" # SONAME
+
+LICENSE="GPL-2"
+IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+
+ASM_DEP=">=dev-lang/nasm-2.13"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+ abi_x86_64? ( ${ASM_DEP} )
+ opencl? ( dev-lang/perl )"
+RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
+
+multilib_src_configure() {
+ tc-export CC
+ local asm_conf=""
+
+ if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
+ asm_conf=" --disable-asm"
+ fi
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ $(usex interlaced "" "--disable-interlaced") \
+ $(usex opencl "" "--disable-opencl") \
+ $(usex static-libs "--enable-static" "") \
+ $(usex threads "" "--disable-thread") \
+ ${asm_conf} || die
+}