summaryrefslogtreecommitdiff
path: root/media-libs/zimg/zimg-3.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 21:21:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 21:21:18 +0000
commitb118032096b3380de251b5de2466f5198fd2930a (patch)
tree992376912dd2522e0078f8350735c14bd0b77149 /media-libs/zimg/zimg-3.0.4-r1.ebuild
parent177349fb1459039cc30cb8e3936af4117d038c16 (diff)
gentoo auto-resync : 10:12:2022 - 21:21:18
Diffstat (limited to 'media-libs/zimg/zimg-3.0.4-r1.ebuild')
-rw-r--r--media-libs/zimg/zimg-3.0.4-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/zimg/zimg-3.0.4-r1.ebuild b/media-libs/zimg/zimg-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..ffef62a46080
--- /dev/null
+++ b/media-libs/zimg/zimg-3.0.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+DEPEND="test? ( dev-cpp/gtest )"
+
+PATCHES=(
+ "${FILESDIR}/system-gtest.patch"
+ "${FILESDIR}/backport-e29571f-issue-175.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable test unit-test)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if ! use static-libs; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}