summaryrefslogtreecommitdiff
path: root/media-libs/zint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-23 19:24:10 +0000
commit575bcb9220287a6f0d2577db1fd9fe55d9d8b745 (patch)
tree52f12cfa140d4839d32305dd42eebe34e9686234 /media-libs/zint
parent4c5bd80830992553e02f099442277e10ee97372d (diff)
gentoo auto-resync : 23:02:2025 - 19:24:09
Diffstat (limited to 'media-libs/zint')
-rw-r--r--media-libs/zint/Manifest3
-rw-r--r--media-libs/zint/metadata.xml17
-rw-r--r--media-libs/zint/zint-2.14.0.ebuild58
3 files changed, 78 insertions, 0 deletions
diff --git a/media-libs/zint/Manifest b/media-libs/zint/Manifest
new file mode 100644
index 000000000000..9db7f6586af6
--- /dev/null
+++ b/media-libs/zint/Manifest
@@ -0,0 +1,3 @@
+DIST zint-2.14.0-src.tar.gz 6261059 BLAKE2B 77bed36f42536fa96f1a69206c221d6f5b09eb25008bfe5e389b3f713eefc0299cf5dbb76f98037bb2af01bf21d6dd0c471ccc24876f7be0829e5d331822dde5 SHA512 ef6b7eb32f7df94ad277877741fbfd0e4f3e534107eeb2938425c51a4e83002a87571dbabe0d6449c41bd42978be575a69955105d6323a0b41b58f7bb8e7ab97
+EBUILD zint-2.14.0.ebuild 1068 BLAKE2B 28cf1288622cc6b6fa45251b1b15f4f7f23269d0d22d41544a2c1880c781c62ddcc558f9f586ef79f1de8775cee3ed861ec7483f2e1710bac9718df9181a553a SHA512 6832dbcaeee622adb8ba61964e2826e66553d4cf03682fb9f5aa96e295c7498a5b7ca2bbe5d0a702683b1886a5f5706dbc3ef8d2feed14ca41eee65df377a312
+MISC metadata.xml 567 BLAKE2B 2c843f2b75d2709d01cbb02a458ca532ea58d6a8bbb620f0348d446a68f9d308327ef71b8aaec159d6e364db250c685a61599fdb474199c970766e5d3a19d87a SHA512 6dfc11fe03606141234e36d5114bb6051bc7e293d96316537dd458ad759f3a73223b000a089ebc2b413baf5153b201a19a51a2bd9d7a897c8d9bcc63d54bd7d4
diff --git a/media-libs/zint/metadata.xml b/media-libs/zint/metadata.xml
new file mode 100644
index 000000000000..133ccd50c190
--- /dev/null
+++ b/media-libs/zint/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <doc>https://www.zint.org.uk/manual/</doc>
+ <remote-id type="github">zint/zint</remote-id>
+ <remote-id type="sourceforge">zint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/zint/zint-2.14.0.ebuild b/media-libs/zint/zint-2.14.0.ebuild
new file mode 100644
index 000000000000..543ef8d6fd42
--- /dev/null
+++ b/media-libs/zint/zint-2.14.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Barcode encoding library supporting over 50 symbologies"
+HOMEPAGE="https://www.zint.org.uk/"
+SRC_URI="
+ https://downloads.sourceforge.net/${PN}/${P}-src.tar.gz
+"
+S="${WORKDIR}/${P}-src"
+
+# see LICENSE
+LICENSE="BSD GPL-3+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="gui png test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ gui? (
+ dev-qt/qtbase:6[gui,widgets]
+ dev-qt/qtsvg:6
+ dev-qt/qttools:6[widgets]
+ )
+ png? (
+ media-libs/libpng:=
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DZINT_FRONTEND=ON
+ -DZINT_QT6=$(usex gui)
+ -DZINT_TEST=$(usex test)
+ -DZINT_UNINSTALL=OFF
+ -DZINT_USE_PNG=$(usex png)
+ -DZINT_USE_QT=$(usex gui)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local -x QT_QPA_PLATFORM=offscreen
+ cmake_src_test -j1 # parallel tests cause failures to each other
+}
+
+src_install() {
+ cmake_src_install
+ einstalldocs
+ if use gui; then
+ domenu zint-qt.desktop
+ doicon zint-qt.png
+ fi
+}