summaryrefslogtreecommitdiff
path: root/media-libs/zita-resampler/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
commit9b55c1bd600df28af7b9f6ee044b714873e19b49 (patch)
tree9c6d86e5e38b0aed45d07dc73907e9f818783a4d /media-libs/zita-resampler/files
parent61044571b76d87a2eec42d36c9b7addf3e66e000 (diff)
gentoo auto-resync : 26:02:2023 - 09:56:20
Diffstat (limited to 'media-libs/zita-resampler/files')
-rw-r--r--media-libs/zita-resampler/files/zita-resampler-1.10.1-makefile.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/zita-resampler/files/zita-resampler-1.10.1-makefile.patch b/media-libs/zita-resampler/files/zita-resampler-1.10.1-makefile.patch
new file mode 100644
index 000000000000..45859759c445
--- /dev/null
+++ b/media-libs/zita-resampler/files/zita-resampler-1.10.1-makefile.patch
@@ -0,0 +1,79 @@
+diff -urpN zita-resampler-1.10.1.orig/apps/Makefile zita-resampler-1.10.1/apps/Makefile
+--- zita-resampler-1.10.1.orig/apps/Makefile 2023-02-17 12:27:32.000000000 +0300
++++ zita-resampler-1.10.1/apps/Makefile 2023-02-19 15:19:08.513618954 +0300
+@@ -23,18 +23,17 @@ BINDIR ?= $(PREFIX)/bin
+ MANDIR ?= /usr/share/man/man1
+
+ VERSION = 1.10.1
+-CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\"
+-CXXFLAGS += -O2 -ffast-math -Wall
+-CXXFLAGS += -march=native
++CPPFLAGS += -MMD -MP -DVERSION=\"$(VERSION)\" -I ../source
++CXXFLAGS += -ffast-math -Wall
+
+
+-all: zresample zretune zresample.1.gz zretune.1.gz
++all: zresample zretune
+
+
+ ZRESAMPLE_O = zresample.o audiofile.o dither.o
+ zresample: LDLIBS += -lzita-resampler -lsndfile -lrt
+ zresample: $(ZRESAMPLE_O)
+- $(CXX) $(LDFLAGS) -o $@ $(ZRESAMPLE_O) $(LDLIBS)
++ $(CXX) -L ../source $(LDFLAGS) -o $@ $(ZRESAMPLE_O) $(LDLIBS)
+ $(ZRESAMPLE_O):
+ -include $(ZRESAMPLE_O:%.o=%.d)
+
+@@ -42,31 +41,24 @@ $(ZRESAMPLE_O):
+ ZRETUNE_O = zretune.o audiofile.o dither.o
+ zretune: LDLIBS += -lzita-resampler -lsndfile -lrt
+ zretune: $(ZRETUNE_O)
+- $(CXX) $(LDFLAGS) -o $@ $(ZRETUNE_O) $(LDLIBS)
++ $(CXX) -L ../source $(LDFLAGS) -o $@ $(ZRETUNE_O) $(LDLIBS)
+ $(ZRETUNE_O):
+ -include $(ZRETUNE_O:%.o=%.d)
+
+
+-zresample.1.gz: zresample.1
+- gzip -c zresample.1 > zresample.1.gz
+-
+-zretune.1.gz: zretune.1
+- gzip -c zretune.1 > zretune.1.gz
+-
+-
+ install: all
+ install -d $(DESTDIR)$(BINDIR)
+ install -d $(DESTDIR)$(MANDIR)
+ install -m 755 zresample $(DESTDIR)$(BINDIR)
+ install -m 755 zretune $(DESTDIR)$(BINDIR)
+- install -m 644 zresample.1.gz $(DESTDIR)$(MANDIR)
+- install -m 644 zretune.1.gz $(DESTDIR)$(MANDIR)
++ install -m 644 zresample.1 $(DESTDIR)$(MANDIR)
++ install -m 644 zretune.1 $(DESTDIR)$(MANDIR)
+
+ uninstall:
+ /bin/rm -f $(DESTDIR)$(BINDIR)/zresample
+ /bin/rm -f $(DESTDIR)$(BINDIR)/zretune
+- /bin/rm -f $(DESTDIR)$(MANDIR)/zresample.1.gz
+- /bin/rm -f $(DESTDIR)$(MANDIR)/zretune.1.gz
++ /bin/rm -f $(DESTDIR)$(MANDIR)/zresample.1
++ /bin/rm -f $(DESTDIR)$(MANDIR)/zretune.1
+
+ clean:
+ /bin/rm -f *~ *.o *.a *.d *.so *.gz zresample zretune
+diff -urpN zita-resampler-1.10.1.orig/source/Makefile zita-resampler-1.10.1/source/Makefile
+--- zita-resampler-1.10.1.orig/source/Makefile 2023-02-17 12:27:32.000000000 +0300
++++ zita-resampler-1.10.1/source/Makefile 2023-02-19 15:07:48.327102241 +0300
+@@ -31,11 +31,9 @@ VERSION = $(MAJVERS).$(MINVERS)
+ DISTDIR = zita-resampler-$(VERSION)
+
+ CPPFLAGS += -I. -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
+-CPPFLAGS += -DENABLE_SSE2
+ CPPFLAGS += -DZITA_RESAMPLER_MAJOR_VERSION=$(MAJVERS)
+ CPPFLAGS += -DZITA_RESAMPLER_MINOR_VERSION=$(MINVERS)
+-CXXFLAGS += -Wall -fPIC -O2 -ffast-math
+-CXXFLAGS += -march=native
++CXXFLAGS += -Wall -fPIC -ffast-math
+ LDFLAGS +=
+ LDLIBS +=
+