summaryrefslogtreecommitdiff
path: root/media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild')
-rw-r--r--media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild b/media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild
index 1a5b81be461d..179215bf472e 100644
--- a/media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild
+++ b/media-plugins/gmpc-magnatune/gmpc-magnatune-11.8.16.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="This plugin allows you to browse and preview available albums on magnatune.com"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_MAGNATUNE"
@@ -12,15 +12,20 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND=">=media-sound/gmpc-${PV}
- dev-libs/libxml2
+RDEPEND="
+ >=media-sound/gmpc-${PV}
+ dev-libs/libxml2:2
dev-db/sqlite:3
>=gnome-base/libglade-2
- || ( x11-libs/gdk-pixbuf:2[jpeg] x11-libs/gtk+:2[jpeg] )"
-DEPEND="${RDEPEND}
+ x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
src_configure() {
econf $(use_enable nls)
@@ -28,5 +33,7 @@ src_configure() {
src_install() {
default
- find "${ED}" -name "*.la" -exec rm {} + || die
+
+ # plugins only
+ find "${D}" -name '*.la' -delete || die
}