summaryrefslogtreecommitdiff
path: root/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild')
-rw-r--r--media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild b/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild
new file mode 100644
index 000000000000..9453e35ea997
--- /dev/null
+++ b/media-plugins/gst-plugins-opencv/gst-plugins-opencv-1.12.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="OpenCV elements for Gstreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/opencv-2.3.0[contrib(+),${MULTILIB_USEDEP}]
+ <media-libs/opencv-3.3.1
+"
+DEPEND="${RDEPEND}"
+
+# Ships the opencv separate helper library as part of gst-plugins-opencv as it depends on OpenCV
+multilib_src_compile() {
+ emake -C gst-libs/gst/opencv
+ gstreamer_multilib_src_compile
+}
+
+multilib_src_install() {
+ emake -C gst-libs/gst/opencv DESTDIR="${D}" install
+ gstreamer_multilib_src_install
+}