summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-inputstream-rtmp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/kodi-inputstream-rtmp
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/kodi-inputstream-rtmp')
-rw-r--r--media-plugins/kodi-inputstream-rtmp/Manifest4
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.4.ebuild35
-rw-r--r--media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild35
-rw-r--r--media-plugins/kodi-inputstream-rtmp/metadata.xml12
4 files changed, 86 insertions, 0 deletions
diff --git a/media-plugins/kodi-inputstream-rtmp/Manifest b/media-plugins/kodi-inputstream-rtmp/Manifest
new file mode 100644
index 000000000000..7b208b7dc810
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/Manifest
@@ -0,0 +1,4 @@
+DIST kodi-inputstream-rtmp-1.0.4.tar.gz 7271 SHA256 75a3cc87243a7c92a0a2e3f16710a1e60d05cd8dbc8b7fd1852244fbc5da2ae8 SHA512 659990b2cbe6e9119c650e151aaae0ccd33f8b9f5d6efd1436f4cb6c78beb51c8fae528b844278348066e1b10fe2a7fa6c05e32b54be82f5a750a5a14c8bd9d2 WHIRLPOOL c5ae973c3c9bff20d4e40ab5366416a14db2f968dd642b2a2cef5cd4c9cdd4959e4547c709084a30a7a0890a3a6dbd4b455200e3dcd1a74d053e0d139dacff05
+EBUILD kodi-inputstream-rtmp-1.0.4.ebuild 659 SHA256 4053f893161168c7d8923460af4acc8f0f50a8ee993dc94f9fb1a3ea15b413ce SHA512 4877df994ca70060b38976fa956ce5e8bfc196dc17c08c79e8c437468a7885fdab7752e9c6a550b861a84322b82d25d186d462f5ef7c613bc5f7fc931bac935b WHIRLPOOL 6f15e8f5affde4394b2728f1b377afca4375f29369a6727b7691e87b9b2c9b6004befcb85220611911d32bfe41300bb6cd8cea3d92caaf4c2ecb7a070189eff2
+EBUILD kodi-inputstream-rtmp-9999.ebuild 660 SHA256 55be0e90a1893b197ce41c16305a4e779b39e06895bd7d0b738e5ee957ea7928 SHA512 2c7ae4993e870fe31b414e5015b501dfb242bb7f57dbfd8f107dab88511be575e9fd5f5e3134066d023c61a87dc10d31002bfd28976cd38c7efb114c235240f4 WHIRLPOOL ec768f217329243a7ad40dd5779f748987857b27e4159f205767a234aaebf914cd3d937114deb0bb78a284671f7292d1f5e7e599d9a6a5fce212235450c68eea
+MISC metadata.xml 437 SHA256 07d18381709b0f17af2d96d4b2849210f27e80bc7bf3f42137e667acbbb3164f SHA512 fc9a96c9a2889e0f4edd80638ba0dd50c4272660f3724ff170c4b34ac71824e8e2b32829826bef8efc2327f6aaa1b694a73049103cd2e772f17324eb05b565ff WHIRLPOOL 99f7a4074ff362d74f2ba07e8d9ac3dd7353d1382e3ec709e26ce46f4a12ba12a0afb1c449c022aedd93049981dcda1f9d6875e643313fbc350af405c27aebda
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.4.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.4.ebuild
new file mode 100644
index 000000000000..8381ea523095
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/notspiff/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/inputstream.rtmp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-17*
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
new file mode 100644
index 000000000000..28be9b91015b
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's RTMP inputstream addon"
+HOMEPAGE="https://github.com/notspiff/inputstream.rtmp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/inputstream.rtmp.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/inputstream.rtmp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/inputstream.rtmp-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-9999
+ media-video/rtmpdump
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-inputstream-rtmp/metadata.xml b/media-plugins/kodi-inputstream-rtmp/metadata.xml
new file mode 100644
index 000000000000..a9d8bb311bc5
--- /dev/null
+++ b/media-plugins/kodi-inputstream-rtmp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <longdescription>Kodi's RTMP inputstream addon</longdescription>
+ <upstream>
+ <remote-id type="github">notspiff/inputstream.rtmp</remote-id>
+ </upstream>
+</pkgmetadata>