summaryrefslogtreecommitdiff
path: root/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild')
-rw-r--r--media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
new file mode 100644
index 000000000000..b84c71c0291f
--- /dev/null
+++ b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="SFTP VFS addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/vfs.sftp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/vfs.sftp.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/vfs.sftp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vfs.sftp-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ net-libs/libssh[sftp]
+ =media-libs/kodi-platform-9999
+ =media-tv/kodi-9999
+ "