summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild')
-rw-r--r--media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild b/media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild
new file mode 100644
index 000000000000..07f704f58a75
--- /dev/null
+++ b/media-plugins/vdr-cdplayer/vdr-cdplayer-1.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: CD-PLAYER"
+HOMEPAGE="http://www.uli-eckhardt.de/vdr/cdplayer.en.shtml"
+SRC_URI="http://www.uli-eckhardt.de/vdr/download/${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="cdparanoia"
+
+DEPEND=">=media-video/vdr-2
+ >=dev-libs/libcdio-0.8.0
+ >=media-libs/libcddb-1.3.0
+ cdparanoia? ( >=dev-libs/libcdio-paranoia-0.90 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ use cdparanoia || BUILD_PARAMS="NOPARANOIA=1"
+}