summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-mplayer/files/0.10.2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-plugins/vdr-mplayer/files/0.10.2
reinit the tree, so we can have metadata
Diffstat (limited to 'media-plugins/vdr-mplayer/files/0.10.2')
-rw-r--r--media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff b/media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff
new file mode 100644
index 000000000000..6eb95c7239ca
--- /dev/null
+++ b/media-plugins/vdr-mplayer/files/0.10.2/01_gentoo.diff
@@ -0,0 +1,33 @@
+diff -Naur mp3-0.10.1.orig/Makefile mp3-0.10.1/Makefile
+--- mp3-0.10.1.orig/Makefile 2008-03-02 16:58:40.988974674 +0100
++++ mp3-0.10.1/Makefile 2008-03-02 16:59:36.879557750 +0100
+@@ -24,14 +24,14 @@
+ # in the VDR directory an set them there.
+
+ ### uncomment one of these lines, if you don't want one of the plugins
+-#WITHOUT_MP3=1
++WITHOUT_MP3=1
+ #WITHOUT_MPLAYER=1
+
+ ### uncomment the following line, if you don't have libsndfile installed
+-#WITHOUT_LIBSNDFILE=1
++WITHOUT_LIBSNDFILE=1
+
+ ### uncomment the following line, if you don't have libvorbisfile installed
+-#WITHOUT_LIBVORBISFILE=1
++WITHOUT_LIBVORBISFILE=1
+
+ ### uncomment the following line, if you want OSS sound output
+ #WITH_OSS_OUTPUT=1
+diff -Naur mp3-0.10.1.orig/mplayer.c mp3-0.10.1/mplayer.c
+--- mp3-0.10.1.orig/mplayer.c 2008-03-02 16:58:41.068960305 +0100
++++ mp3-0.10.1/mplayer.c 2008-03-02 17:00:53.845333952 +0100
+@@ -832,7 +832,7 @@
+ #else
+ i18n_name="vdr-mplayer";
+ #endif
+- MPlaySources.Load(AddDirectory(ConfigDirectory(sourcesSub),"mplayersources.conf"));
++ MPlaySources.Load(AddDirectory(ConfigDirectory(sourcesSub),"mplayer/mplayersources.conf"));
+ if(MPlaySources.Count()<1) {
+ esyslog("ERROR: you must have defined at least one source in mplayersources.conf");
+ fprintf(stderr,"No source(s) defined in mplayersources.conf\n");