summaryrefslogtreecommitdiff
path: root/media-plugins/vdr-music
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-plugins/vdr-music
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-plugins/vdr-music')
-rw-r--r--media-plugins/vdr-music/Manifest4
-rw-r--r--media-plugins/vdr-music/files/music.mk198
-rw-r--r--media-plugins/vdr-music/metadata.xml8
-rw-r--r--media-plugins/vdr-music/vdr-music-0.9.9.ebuild54
4 files changed, 0 insertions, 264 deletions
diff --git a/media-plugins/vdr-music/Manifest b/media-plugins/vdr-music/Manifest
deleted file mode 100644
index 20fb92c66cf4..000000000000
--- a/media-plugins/vdr-music/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX music.mk 4798 BLAKE2B 2b592f92df9be9340a0d6893ed68000b01c602f6676d565bd295ef8f73adae2c62da26a5c5b8522d9587bad69ab413f8c42a8e24b1bbf7901cf8d6e554e1e483 SHA512 c50cd6d9aea30b69f2e1a22f10fe23c855f18028e6be7de9268e53fa666ab126fa8fac5b2652f3b1b99c238d1d6be47d5052979d82456274eaeb79217f7c4198
-DIST vdr-music-0.9.9-dev2.tgz 2189767 BLAKE2B a4ece0904304d7b9cc13532e5ce6833508cf69137dbec7d2e28cac7dc77128344f23183a40d863bba9476f19490d4b26baa9dbfab298161c4e89619544768d1a SHA512 65d9d6b1c76144dfcdb67d884c6cb44066c2bb15ccad0da1e011941b54695f47e4ae104397db1d77d6108ec7cdd81b785901a05fa1c6e07e42df71d021ab1fa7
-EBUILD vdr-music-0.9.9.ebuild 1536 BLAKE2B ee674bcb52fc20833a0ed612ee441a10812f4b8657a4d0b40a5e0bcb4e80ec317bfbb3d12dc6c653da3b16e6cdf8bdc33b520b3380f4b193d73d383ae10dc308 SHA512 21643d10602acb8db2c64cc66eb15ec96f38049f917959a5a50f1e553d83059db8facbb73c15517a4fc1a73ebf0c26457a5d36326d37eac0b779428602cc6b5e
-MISC metadata.xml 243 BLAKE2B 6287033e852823666551691771936aead83e7394d6c41f6f5a43a4c21309300e6fcfd90e8a87a82eb90433f86344426c07f2fb7833e7226d2e3c4df9fda1d2d6 SHA512 f7d6e467a5a96c0afdd42df3c0f3866240defc5bbea5ccddf4c0b1a3c004225af5d46dab67d45a5ac34535391584f3b3727fe79ef6cef1a11413636bbc35cf06
diff --git a/media-plugins/vdr-music/files/music.mk b/media-plugins/vdr-music/files/music.mk
deleted file mode 100644
index 0ff1d5893e1e..000000000000
--- a/media-plugins/vdr-music/files/music.mk
+++ /dev/null
@@ -1,198 +0,0 @@
-#
-# Makefile for a Video Disk Recorder plugin
-#
-
-# The official name of this plugin.
-# This name will be used in the '-P...' option of VDR to load the plugin.
-# By default the main source file also carries this name.
-
-PLUGIN = music
-
-### The version number of this plugin (taken from the main source file):
-
-VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
-
-### The directory environment:
-
-# Use package data if installed...otherwise assume we're under the VDR source directory:
-PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
-LIBDIR = $(call PKGCFG,libdir)
-LOCDIR = $(call PKGCFG,locdir)
-PLGCFG = $(call PKGCFG,plgcfg)
-#
-TMPDIR ?= /tmp
-
-### The compiler options:
-
-export CFLAGS = $(call PKGCFG,cflags)
-export CXXFLAGS = $(call PKGCFG,cxxflags)
-
-### The version number of VDR's plugin API:
-
-APIVERSION = $(call PKGCFG,apiversion)
-
-### Allow user defined options to overwrite defaults:
-
--include $(PLGCFG)
-
-### The name of the distribution archive:
-
-ARCHIVE = $(PLUGIN)-$(VERSION)
-PACKAGE = vdr-$(ARCHIVE)
-
-### The name of the shared object file:
-
-SOFILE = libvdr-$(PLUGIN).so
-
-### Includes and Defines (add further entries here):
-
-# (Default) DO NOT UNCOMMENT IT IN DEVELOPER-VERSIONS
-HAVE_IMAGEMAGICK=1
-# Uncomment the following line, if you don't have libsndfile installed
-#WITHOUT_LIBSNDFILE=1
-
-# Uncomment the following line, if you don't have libvorbisfile installed
-#WITHOUT_LIBVORBISFILE=1
-
-#BROKEN_PCM=1
-# Uncomment if you want debug output on stdout
-##DEBUG=1
-
-# internal use
-# BUGHUNT
-#BUGHUNT=1
-
-# internal use
-# DEBUG_COVER
-#DEBUG_COVER=1
-
-###INCLUDES +=
-
-###DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
-INCLUDES += -I$(VDRINCDIR)
-
-DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
-
-ifdef BROKEN_PCM
- DEFINES += -DBROKEN_PCM
-endif
-
-ifeq ($(shell test -f $(VDRDIR)/fontsym.h ; echo $$?),0)
- DEFINES += -DHAVE_BEAUTYPATCH
-endif
-
-ifdef DBG
- CXXFLAGS += -g
-endif
-
-ifdef DEBUG
- DEFINES += -DDEBUG
-else
- DEFINES += -DNO_DEBUG
-endif
-
-ifdef BUGHUNT
- DEFINES += -DBUGHUNT
-endif
-
-ifdef DEBUG_COVER
- DEFINES += -DDEBUG_COVER
-endif
-
-### The object files (add further files here):
-
-OBJS = $(PLUGIN).o config.o vars.o bitmap.o \
- commands.o options.o lyrics.o funct.o cover.o skin.o visual.o tracklist.o \
- search.o mp3id3.o mp3id3tag.o rating.o menubrowse.o mp3control.o \
- icons.o data.o menu.o \
- data-mp3.o setup-mp3.o player-mp3.o stream.o network.o \
- decoder.o decoder-mp3.o decoder-mp3-stream.o decoder-snd.o \
- decoder-ogg.o
-
-LIBS += -lasound -lmad -lid3tag
-
-ifdef HAVE_IMAGEMAGICK
- INCLUDES += $(shell pkg-config --cflags MagickCore)
- LIBS += $(shell pkg-config --libs Magick++)
- DEFINES += -DHAVE_IMAGEMAGICK
-else
- INCLUDES += -I$(IMLIB)/src
- LIBS += $(shell imlib2-config --libs)
- DEFINES += -DHAVE_IMLIB2
-endif
-
-ifndef WITHOUT_LIBSNDFILE
- LIBS += -lsndfile
- DEFINES += -DHAVE_SNDFILE
-endif
-
-ifndef WITHOUT_LIBVORBISFILE
- LIBS += -lvorbisfile -lvorbis
- DEFINES += -DHAVE_VORBISFILE
-endif
-
-### The main target:
-
-all: $(SOFILE) i18n
-
-### Implicit rules:
-
-%.o: %.c
- $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
-
-### Dependencies:
-
-MAKEDEP = $(CXX) -MM -MG
-DEPFILE = .dependencies
-$(DEPFILE): Makefile
- @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
-
--include $(DEPFILE)
-
-### Internationalization (I18N):
-
-PODIR = po
-I18Npo = $(wildcard $(PODIR)/*.po)
-I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
-I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
-I18Npot = $(PODIR)/$(PLUGIN).pot
-
-%.mo: %.po
- msgfmt -c -o $@ $<
-
-$(I18Npot): $(wildcard *.c)
- xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
-
-%.po: $(I18Npot)
- msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
- @touch $@
-
-$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
- install -D -m644 $< $@
-
-.PHONY: i18n
-i18n: $(I18Nmo) $(I18Npot)
-
-install-i18n: $(I18Nmsgs)
-
-### Targets:
-
-$(SOFILE): $(OBJS)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
-
-install-lib: $(SOFILE)
- install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
-
-install: install-lib install-i18n
-
-dist: $(I18Npo) clean
- @-rm -rf $(TMPDIR)/$(ARCHIVE)
- @mkdir $(TMPDIR)/$(ARCHIVE)
- @cp -a * $(TMPDIR)/$(ARCHIVE)
- @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
- @-rm -rf $(TMPDIR)/$(ARCHIVE)
- @echo Distribution package created as $(PACKAGE).tgz
-
-clean:
- @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
- @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-music/metadata.xml b/media-plugins/vdr-music/metadata.xml
deleted file mode 100644
index 27f419c289c3..000000000000
--- a/media-plugins/vdr-music/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-<email>vdr@gentoo.org</email>
-<name>Gentoo VDR Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/media-plugins/vdr-music/vdr-music-0.9.9.ebuild b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
deleted file mode 100644
index a9a7a268fc82..000000000000
--- a/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit vdr-plugin-2
-
-MY_P="${P}-dev2"
-S="${WORKDIR}/music-${PV}-dev2"
-
-DESCRIPTION="VDR plugin: music"
-HOMEPAGE="http://www.vdr.glaserei-franz.de/vdrplugins.htm"
-SRC_URI="http://www.glaserei-franz.de/VDR/Moronimo/files/${MY_P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="+imagemagick debug sndfile vorbis"
-
-DEPEND=">=media-video/vdr-1.6.0
- media-libs/libmad
- media-libs/libid3tag
- imagemagick? ( media-gfx/imagemagick[png] )
- sndfile? ( media-libs/libsndfile )
- vorbis? ( media-libs/libvorbis )
- !imagemagick? ( media-libs/imlib2[png] )"
-
-RDEPEND="sys-process/at
- media-sound/id3v2"
-
-src_prepare() {
-# # prepare sources with new Makefile handling
-# cp "${FILESDIR}/music.mk" "${S}"/Makefile
-
- # clean up from untranslated .po files
- rm "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,it_IT,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
-
- vdr-plugin-2_src_prepare
-
- use !vorbis && sed -i Makefile -e "s:#WITHOUT_LIBVORBISFILE=1:WITHOUT_LIBVORBISFILE=1:"
- use !sndfile && sed -i Makefile -e "s:#WITHOUT_LIBSNDFILE=1:WITHOUT_LIBSNDFILE=1:"
- use !debug && sed -i Makefile -e "s:DEBUG=1:#DEBUG=1:"
- use imagemagick && sed -i Makefile \
- -e "s:#HAVE_MAGICK=1:HAVE_MAGICK=1:" \
- -e "s:#MAGICKDIR=:MAGICKDIR=:"
-}
-
-src_install() {
- vdr-plugin-2_src_install
-
- insinto /etc/vdr/plugins/music
- doins -r moronsuite/music/*
- chown -R vdr:vdr "${D}"/etc/vdr/plugins/music
-}