summaryrefslogtreecommitdiff
path: root/media-radio/ax25-apps/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-radio/ax25-apps/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-radio/ax25-apps/files')
-rw-r--r--media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch12
-rw-r--r--media-radio/ax25-apps/files/ax25ipd.rc19
-rw-r--r--media-radio/ax25-apps/files/ax25mond.rc19
-rw-r--r--media-radio/ax25-apps/files/ax25rtd.rc19
4 files changed, 69 insertions, 0 deletions
diff --git a/media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch b/media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch
new file mode 100644
index 000000000000..ee1c2ffd92b6
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25-apps-0.8.4-tinfo.patch
@@ -0,0 +1,12 @@
+# fix tinof handling (bug 529776)
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,7 +17,7 @@
+ AC_SUBST(AX25_LIB)
+ AC_SUBST(NCURSES_LIB)
+ AC_CHECK_LIB(ax25, ax25_config_load_ports, AX25_LIB="-lax25", AC_MSG_ERROR(Could not find the libax25 libraries; aborting))
+-AC_CHECK_LIB(ncurses, initscr,NCURSES_LIB="-lncurses", AC_MSG_ERROR(Could not find the ncurses library; aborting))
++PKG_CHECK_MODULES(ncurses, ncurses, [NCURSES_LIB="$ncurses_LIBS"], AC_MSG_ERROR(Could not find the ncurses library))
+
+ dnl Checks for working glibc 2.1 headers
+ AC_CHECK_TYPES([struct ax25_fwd_struct], [],
diff --git a/media-radio/ax25-apps/files/ax25ipd.rc b/media-radio/ax25-apps/files/ax25ipd.rc
new file mode 100644
index 000000000000..f14be48d3e82
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25ipd.rc
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25ipd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25ipd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25ipd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25ipd
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/ax25mond.rc b/media-radio/ax25-apps/files/ax25mond.rc
new file mode 100644
index 000000000000..fc5be3d07b20
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25mond.rc
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25mond"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25mond
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25mond"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25mond
+ eend $?
+}
diff --git a/media-radio/ax25-apps/files/ax25rtd.rc b/media-radio/ax25-apps/files/ax25rtd.rc
new file mode 100644
index 000000000000..53fb572c5337
--- /dev/null
+++ b/media-radio/ax25-apps/files/ax25rtd.rc
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ax25rtd"
+ start-stop-daemon --start --quiet --background --exec /usr/sbin/ax25rtd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ax25rtd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ax25rtd
+ eend $?
+}