summaryrefslogtreecommitdiff
path: root/media-radio/tlf/tlf-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /media-radio/tlf/tlf-1.4.1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'media-radio/tlf/tlf-1.4.1.ebuild')
-rw-r--r--media-radio/tlf/tlf-1.4.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-1.4.1.ebuild b/media-radio/tlf/tlf-1.4.1.ebuild
new file mode 100644
index 000000000000..f247636cf630
--- /dev/null
+++ b/media-radio/tlf/tlf-1.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf --enable-fldigi-xmlrpc
+}