summaryrefslogtreecommitdiff
path: root/media-sound/apetag
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/apetag
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/apetag')
-rw-r--r--media-sound/apetag/Manifest2
-rw-r--r--media-sound/apetag/apetag-1.12-r3.ebuild57
-rw-r--r--media-sound/apetag/files/apetag-1.12-py3.patch112
3 files changed, 171 insertions, 0 deletions
diff --git a/media-sound/apetag/Manifest b/media-sound/apetag/Manifest
index 0323684c7fe7..453133c9ee95 100644
--- a/media-sound/apetag/Manifest
+++ b/media-sound/apetag/Manifest
@@ -1,3 +1,5 @@
+AUX apetag-1.12-py3.patch 3784 BLAKE2B 039a42333dd48c0b2f3562411a53be1c793b5c19b9c9afc711e16a4b8a959fdc7a2fa8564c71eb99be403d596700a98e28529a39a45bffbd3315f42571085255 SHA512 325defd7e7114406185af0547d2d53cbf7a92a365016d9e7a08d12dec14fb5b364ac1051c86db67ce2e37066db83b9a7c9995cd7a6e1fd3b1b04a39d22651f8e
DIST apetag.1.12.tar.gz 29942 BLAKE2B 866f0ed90b9bcdbed3c0a35729327058806478d1c17a7f88528809b1480a2a55f4665ce809737010cc3b642b6ed99ec22db84b7b6ec4b14f73974274f3e31bc5 SHA512 615c495721c6d46e6ce4546ede218efaac1f3fda91dcd9b8da2b8f7c79cc0f5fbee7dd5bc433c0b125973a816980abb8677f16d4000e5e71699524baddd16887
EBUILD apetag-1.12-r2.ebuild 984 BLAKE2B 3aa9e1aace83ecb791d364bf015cc92195eb17a193c2910c40594557b0093cc0a94dadb378ab5abc7ed995e93006a63d173101144928e95d48564eddf3f55287 SHA512 c9b821fd2e66627a6133ab39ddb21fca70d3711061984d6d80df34c7aa1a0407e0d7f969879a88b4a087626341b70eb9bb8a902da8d7e921326187a5fe3a21c2
+EBUILD apetag-1.12-r3.ebuild 1046 BLAKE2B b534684c1a95c1ca2f5037e9c71813a6599dd474f37efa6cab9bc142cfb6982b5f66e8d952316806b328e806b5537f4dba550fdad20b2dd1e09de79747005d0b SHA512 171d86ee6b0f25a1d7ba3be3c08be8e858a27a09f04dd8ed3b867381bc26309899829af50c546fca14bd96fdbb25d96d67e06b62e27a4ee9d26a7d5669652d07
MISC metadata.xml 259 BLAKE2B 7339f463fc3fa87e1aba5665d97d0878dfd0ccdc4570e76adb531ce80090b0fd0eadf7ee78e3d081cd48083a800c5ecb395255df40d35f8745471346cf07ff16 SHA512 7315c86cee93f8109e30dd379dde35c51ad60e759a037cc8ee3feeec369434d65fecf785480861e7fc6a17baaf81517083284783b4b35143c911da98846d0360
diff --git a/media-sound/apetag/apetag-1.12-r3.ebuild b/media-sound/apetag/apetag-1.12-r3.ebuild
new file mode 100644
index 000000000000..c485ce960902
--- /dev/null
+++ b/media-sound/apetag/apetag-1.12-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Command-line ape 2.0 tagger"
+HOMEPAGE="http://muth.org/Robert/Apetag/"
+SRC_URI="http://muth.org/Robert/Apetag/${PN}.${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN^}
+
+DOCS=( 00readme )
+
+PATCHES=(
+ "${FILESDIR}/${P}-py3.patch"
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:CXXDEBUG:LDFLAGS:' \
+ Makefile || die
+ python_fix_shebang *.py
+}
+
+src_compile() {
+ tc-export CXX
+ emake \
+ CXXFLAGS="${CXXFLAGS} -Wall -pedantic" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+
+ python_moduleinto /usr/lib/apetag
+ python_domodule *.py
+
+ fperms +x /usr/lib/apetag/{rmid3tag,tagdir}.py
+ dosym ../lib/apetag/rmid3tag.py /usr/bin/rmid3tag.py
+ dosym ../lib/apetag/tagdir.py /usr/bin/tagdir.py
+
+ einstalldocs
+}
diff --git a/media-sound/apetag/files/apetag-1.12-py3.patch b/media-sound/apetag/files/apetag-1.12-py3.patch
new file mode 100644
index 000000000000..c91f5c1a37a0
--- /dev/null
+++ b/media-sound/apetag/files/apetag-1.12-py3.patch
@@ -0,0 +1,112 @@
+diff --git a/cddb.py b/cddb.py
+index f30b3b7..c9cb6dd 100755
+--- a/cddb.py
++++ b/cddb.py
+@@ -131,7 +131,7 @@ class Toc:
+ track = int(match.group(1))
+ self._trackext[track] = self._trackext[track] + match.group(2)
+ continue
+- raise SyntaxError, "BAD LINE:" + line
++ raise SyntaxError("BAD LINE:" + line)
+
+ components = self._disctitle.split("/", 1)
+ self._discartist = components[0].strip()
+@@ -160,18 +160,18 @@ class Toc:
+ return len(self._tracktitle)
+
+ def dump(self):
+- print "DISCID: " + self._discid
+- print "DISCTITLE: " + self._disctitle
+- print "DISKEXT: " + self._discext
+- print "TRACK TITLES"
++ print("DISCID: " + self._discid)
++ print("DISCTITLE: " + self._disctitle)
++ print("DISKEXT: " + self._discext)
++ print("TRACK TITLES")
+ for k in range(len(self._tracktitle)):
+- print "%2d:" % k, self._tracktitle[k]
+- print "TRACK EXTS"
++ print("%2d:" % k, self._tracktitle[k])
++ print("TRACK EXTS")
+ for k in range(len(self._trackext)):
+- print "%2d:" % k, self._trackext[k]
+- print "TRACK TIMES"
++ print("%2d:" % k, self._trackext[k])
++ print("TRACK TIMES")
+ for k in range(len(self._tracktimes)):
+- print "%2d:" % k, self._tracktimes[k]
++ print("%2d:" % k, self._tracktimes[k])
+ return
+
+ # ======================================================================
+diff --git a/rmid3tag.py b/rmid3tag.py
+index 36abe7f..e218638 100755
+--- a/rmid3tag.py
++++ b/rmid3tag.py
+@@ -32,7 +32,7 @@ import logging
+
+ # ======================================================================
+ def usage():
+- print USAGE
++ print(USAGE)
+ return -1
+
+ # ======================================================================
+@@ -44,7 +44,7 @@ def process_file(name):
+ pos = inp.tell()
+ tag = inp.read(3)
+ if tag == "TAG":
+- print name + ": found id3v1 tag - truncating at 0x%08x" % pos
++ print(name + ": found id3v1 tag - truncating at 0x%08x" % pos)
+ inp.truncate(pos)
+ else:
+ logging.warning(name + ": no id3v1 tag found\n")
+diff --git a/tagdir.py b/tagdir.py
+index 87223ef..f45aa9a 100755
+--- a/tagdir.py
++++ b/tagdir.py
+@@ -188,7 +188,7 @@ def tag_files(files, toc, cmdpattern, test, verbose):
+
+ realcmd = [tok % args for tok in cmdpattern]
+ if verbose:
+- print realcmd
++ print(realcmd)
+ if not test:
+ ret = os.spawnvp(os.P_WAIT, realcmd[0], realcmd)
+ if ret:
+@@ -201,7 +201,7 @@ def mode_dump(files):
+ perform read test and all (toc) files and dump their content
+ """
+ for i in files:
+- print "TOC: ", i
++ print("TOC: ", i)
+ if not os.access(i, os.R_OK):
+ logging.warning("cannot open " + i)
+ continue
+@@ -218,7 +218,7 @@ def mode_toc(tocpath, test, check, verbose):
+ """
+ try:
+ toc = cddb.Toc(tocpath)
+- except Exception, ex:
++ except Exception as ex:
+ logging.error("cannot open toc file at %s %s",
+ os.path.abspath(tocpath), str(ex))
+ return -1
+@@ -261,7 +261,7 @@ def main(argv):
+ try:
+ opts, args = getopt.getopt(argv, "t:m:v")
+ except getopt.error:
+- print USAGE
++ print(USAGE)
+ return -1
+
+ mode = "tag"
+@@ -276,7 +276,7 @@ def main(argv):
+ verbose = 1
+ else:
+ logging.error("bad option: >" + opt + "<")
+- print USAGE
++ print(USAGE)
+ return -1
+ if mode == "dump":
+ return mode_dump(args)