summaryrefslogtreecommitdiff
path: root/media-sound/audacious/audacious-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /media-sound/audacious/audacious-9999.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'media-sound/audacious/audacious-9999.ebuild')
-rw-r--r--media-sound/audacious/audacious-9999.ebuild37
1 files changed, 17 insertions, 20 deletions
diff --git a/media-sound/audacious/audacious-9999.ebuild b/media-sound/audacious/audacious-9999.ebuild
index 47a2fb255287..282261cbea55 100644
--- a/media-sound/audacious/audacious-9999.ebuild
+++ b/media-sound/audacious/audacious-9999.ebuild
@@ -1,32 +1,26 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit gnome2-utils xdg-utils
-
MY_P="${P/_/-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Lightweight and versatile audio player"
-HOMEPAGE="https://audacious-media-player.org/"
if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/audacious-media-player/audacious.git"
else
- SRC_URI="
- !gtk3? ( https://distfiles.audacious-media-player.org/${MY_P}.tar.bz2 )
- gtk3? ( https://distfiles.audacious-media-player.org/${MY_P}-gtk3.tar.bz2 )"
+ SRC_URI="https://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
+inherit gnome2-utils xdg-utils
+DESCRIPTION="Lightweight and versatile audio player"
+HOMEPAGE="https://audacious-media-player.org/"
SRC_URI+=" mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
-IUSE="gtk gtk3 nls qt5"
-REQUIRED_USE="^^ ( gtk gtk3 qt5 )"
+IUSE="nls qt5"
RDEPEND="
>=dev-libs/dbus-glib-0.60
@@ -34,28 +28,31 @@ RDEPEND="
>=x11-libs/cairo-1.2.6
>=x11-libs/pango-1.8.0
virtual/freedesktop-icon-theme
- gtk? ( x11-libs/gtk+:2 )
- gtk3? ( x11-libs/gtk+:3 )
+ !qt5? ( x11-libs/gtk+:2 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
- )"
+ )
+"
DEPEND="${RDEPEND}
virtual/pkgconfig
- nls? ( dev-util/intltool )"
+ nls? ( dev-util/intltool )
+"
PDEPEND="~media-plugins/audacious-plugins-${PV}"
+S="${WORKDIR}/${MY_P}"
+
src_unpack() {
default
- if use gtk3; then
- mv "${MY_P}"{-gtk3,} || die
- fi
[[ ${PV} == *9999 ]] && git-r3_src_unpack
}
src_prepare() {
default
+ if ! use nls; then
+ sed -e "/SUBDIRS/s/ po//" -i Makefile || die # bug #512698
+ fi
[[ ${PV} == *9999 ]] && eautoreconf
}
@@ -68,8 +65,8 @@ src_configure() {
econf \
--disable-valgrind \
--enable-dbus \
- $(use_enable $(usex gtk gtk gtk3) gtk) \
$(use_enable nls) \
+ $(use_enable !qt5 gtk) \
$(use_enable qt5 qt)
}