summaryrefslogtreecommitdiff
path: root/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild')
-rw-r--r--media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild b/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild
new file mode 100644
index 000000000000..3f77ce8b3634
--- /dev/null
+++ b/media-sound/bpmdetect/bpmdetect-0.7.0_pre20170810.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=b13aac15904c1f821b1739d00445f49432705387
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Automatic BPM detection utility"
+HOMEPAGE="https://github.com/Tatsh/bpmdetect"
+SRC_URI="https://github.com/Tatsh/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ media-libs/flac
+ media-libs/libmad
+ media-libs/libvorbis
+ media-libs/portaudio
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_install() {
+ einstalldocs
+ dobin "${BUILD_DIR}"/src/${PN}
+}