summaryrefslogtreecommitdiff
path: root/media-sound/brutefir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /media-sound/brutefir
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'media-sound/brutefir')
-rw-r--r--media-sound/brutefir/Manifest1
-rw-r--r--media-sound/brutefir/brutefir-1.0k-r2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/brutefir/Manifest b/media-sound/brutefir/Manifest
index 3636c685c4ec..6a3ed9a02769 100644
--- a/media-sound/brutefir/Manifest
+++ b/media-sound/brutefir/Manifest
@@ -1,4 +1,5 @@
AUX brutefir-1.0k-ld.patch 4655 BLAKE2B 56ae2cf653311030e5552e50653082b059baa39bf00d1d9a2692e319b459a88b4bef4e0a1aa01aedd2ec9c97f19de0f03b966d10c6faeeccd6ef907d91b12a59 SHA512 606d32f1b76901e3cb6d106259d19c64e3a6f841fd5d0791623ad824c7264ff3ecd7178073fe488c7f1d26b996b9900f9661406f987f2443e9eb8ef9eeb6491a
DIST brutefir-1.0k.tar.gz 246987 BLAKE2B 3db08c1f51e8febb63b293d1a242342e7d9f4fa4b447b46da37bc3de594bef8a6ee15cd8330ef73673011186dcfe47a5b056ec3c177f3982cd1837a582f050a1 SHA512 5eb81a18935fc3f014613b74c30b2e9a3acfe0ab58b72358f0428b60f0296ab54796b99fa00b12a671935b57589d710dd81b1e0ca675bd2b841c9e932a2c94ef
EBUILD brutefir-1.0k-r1.ebuild 1217 BLAKE2B 0dd758e2e3d319e0b376b9f00f7ade1bbef1dc74a5a5f399dc516ae311ff9671a4a91e355d06cdbaa1835318c1778321dd7568999c862aaf6f795a6f38681437 SHA512 86a2d22827c14dd89105976676f7c9e48143a610b07e3ea53e5cf7536716ee4acaec0eea1ebd78d3879b0c1c6c45e2fbe30983d57bb14409232453df02951dae
+EBUILD brutefir-1.0k-r2.ebuild 1108 BLAKE2B 6cb5824eea3e58cac26ff40c9cc412dc081e39f35bd85aa9cda77e268f422f9a82587c622f85f86cacd5972614708d5fd0e513dce2d3e6bdada8428c527af6b7 SHA512 1fd4f6f28008770336559eca2077af00185c6b91f6bf72deac652a6934548ade23ceabc69fd87f1a194b6f20767e99e622e243a253aa151444b0e29a4e8f27ec
MISC metadata.xml 249 BLAKE2B f7f8f071ecba933f3d39b0b60983281d59299b92de9375a60ab4109d7202800cb790bce0c426227f04b3e2624b1adb20876145741355abc6a4938b8b9698d144 SHA512 9a100fb26586365eda99724330a03a512f4d0be18d39c3a195ba02c2fc841edeee99d22512acf5a058a3b978d3a74f4d963a5aff9aa343b6cb4086cdfefe6343
diff --git a/media-sound/brutefir/brutefir-1.0k-r2.ebuild b/media-sound/brutefir/brutefir-1.0k-r2.ebuild
new file mode 100644
index 000000000000..c4bc957fd6f7
--- /dev/null
+++ b/media-sound/brutefir/brutefir-1.0k-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Software convolution engine for applying long FIR filters"
+HOMEPAGE="https://www.ludd.ltu.se/~torger/brutefir.html"
+SRC_URI="https://www.ludd.ltu.se/~torger/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ld.patch )
+
+src_compile() {
+ tc-export AS CC
+ emake
+}
+
+src_install() {
+ emake LIBDIR="/usr/$(get_libdir)" DESTDIR="${D}" \
+ install
+ dodoc CHANGES README
+
+ insinto /usr/share/${PN}
+ doins xtc_config directpath.txt crosspath.txt massive_config \
+ bench1_config bench2_config bench3_config bench4_config \
+ bench5_config
+}
+
+pkg_postinst() {
+ elog "Brutefir is a complicated piece of software. Please"
+ elog "read the documentation first! You can find"
+ elog "documentation here: http://www.ludd.luth.se/~torger/brutefir.html"
+ elog "Example config files are in /usr/share/brutefir"
+}