summaryrefslogtreecommitdiff
path: root/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 03:08:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 03:08:54 +0100
commitcdb747b791914a30c287a3a8e33d1b635e431707 (patch)
treebe22ab4ebfae7f170acb577486d0edc7e6d14279 /media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch
parent496936ff0f7db69d1f7317341230acb866e3c330 (diff)
gentoo auto-resync : 30:07:2022 - 03:08:54
Diffstat (limited to 'media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch')
-rw-r--r--media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch b/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch
new file mode 100644
index 000000000000..591d56ad1867
--- /dev/null
+++ b/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -3,16 +3,13 @@
+ #CC = /usr/local/bin/g++
+ #CC = /usr/bin/g++
+
+-CFLAGS = -O2 -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+-
+-.c.o:
+- gcc $(CFLAGS) -c $<
++CFLAGS += -Wall
++CPPFLAGS += -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+ OBJECT =\
+ combine_wave.o
+
+-a.out : $(OBJECT)
+- gcc -o combine_wave $(OBJECT)
++all: combine_wave
+
+ # DEPENDENCIES
+ combine_wave.o : combine_wave.c combine_wave.h wave_header.h