summaryrefslogtreecommitdiff
path: root/media-sound/deinvert/deinvert-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /media-sound/deinvert/deinvert-9999.ebuild
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'media-sound/deinvert/deinvert-9999.ebuild')
-rw-r--r--media-sound/deinvert/deinvert-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/deinvert/deinvert-9999.ebuild b/media-sound/deinvert/deinvert-9999.ebuild
new file mode 100644
index 000000000000..8f9dfb0b0b80
--- /dev/null
+++ b/media-sound/deinvert/deinvert-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3 autotools
+
+DESCRIPTION="A voice inversion descrambler"
+HOMEPAGE="https://github.com/windytan/deinvert"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/windytan/deinvert.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="+liquid +wav"
+
+DEPEND="liquid? ( net-libs/liquid-dsp )
+ wav? ( media-libs/libsndfile )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with liquid) \
+ $(use_with wav sndfile)
+}