summaryrefslogtreecommitdiff
path: root/media-sound/ecasound/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/ecasound/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/ecasound/files')
-rw-r--r--media-sound/ecasound/files/ecasound-2.8.1-ldflags.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/ecasound/files/ecasound-2.8.1-ldflags.patch b/media-sound/ecasound/files/ecasound-2.8.1-ldflags.patch
new file mode 100644
index 000000000000..8dca486f06e1
--- /dev/null
+++ b/media-sound/ecasound/files/ecasound-2.8.1-ldflags.patch
@@ -0,0 +1,64 @@
+--- ecasound-2.8.1.orig/kvutils/Makefile.am
++++ ecasound-2.8.1/kvutils/Makefile.am
+@@ -56,13 +56,12 @@
+ kvu_value_queue.h
+
+ libkvutils_la_SOURCES = $(kvutil_sources) $(kvutil_headers)
+-libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@ -static
++libkvutils_la_LDFLAGS = -version-info @LIBKVUTILS_VERSION@:0:@LIBKVUTILS_VERSION_AGE@
+
+ libkvutils_debug_la_SOURCES = $(libkvutils_la_SOURCES)
+ libkvutils_debug_la_LDFLAGS = $(libkvutils_la_LDFLAGS)
+
+ libkvutils_tester_SOURCES = libkvutils_tester.cpp
+-libkvutils_tester_LDFLAGS = -static
+ libkvutils_tester_LDADD = $(lib_LTLIBRARIES)
+
+ noinst_HEADERS = $(kvutil_headers)
+--- ecasound-2.8.1.orig/libecasound/Makefile.am
++++ ecasound-2.8.1/libecasound/Makefile.am
+@@ -364,7 +364,7 @@
+
+ libecasound_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
+ libecasound_debug_la_SOURCES = $(ecasound_common1_src) $(ecasound_common2_src)
+-libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags) -static
++libecasound_la_LDFLAGS = -export-dynamic $(eca_ldflags)
+ libecasound_la_LIBADD = $(eca_libadd)
+ libecasound_debug_la_LDFLAGS = $(libecasound_la_LDFLAGS)
+ libecasound_debug_la_LIBADD = $(libecasound_la_LIBADD)
+--- ecasound-2.8.1.orig/libecasound/plugins/Makefile.am
++++ ecasound-2.8.1/libecasound/plugins/Makefile.am
+@@ -105,7 +105,7 @@
+ libecasound_plugins_la_SOURCES = audioio_dummy.cpp $(plugin_cond_sources)
+ EXTRA_libecasound_plugins_la_SOURCES = $(plugin_all_sources)
+ libecasound_plugins_la_LIBADD = $(ECA_S_EXTRA_LIBS)
+-libecasound_plugins_la_LDFLAGS = -static
++libecasound_plugins_la_LDFLAGS =
+
+ libecasound_plugins_debug_la_SOURCES = $(libecasound_plugins_la_SOURCES)
+ EXTRA_libecasound_plugins_debug_la_SOURCES = $(EXTRA_libecasound_plugins_la_SOURCES)
+--- ecasound-2.8.1.orig/libecasoundc/Makefile.am
++++ ecasound-2.8.1/libecasoundc/Makefile.am
+@@ -14,9 +14,9 @@
+ # !!!
+ # remember to update eca-version.cpp
+ if ECA_AM_DEBUG_MODE
+-eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
++eca_ldflags = -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@
+ else
+-eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@ -static
++eca_ldflags = -s -version-info @LIBECASOUNDC_VERSION@:0:@LIBECASOUNDC_VERSION_AGE@
+ endif
+
+ INCLUDES = -I$(srcdir)
+--- ecasound-2.8.1.orig/pyecasound/Makefile.am
++++ ecasound-2.8.1/pyecasound/Makefile.am
+@@ -28,7 +28,7 @@
+ $(DESTDIR)$(ECA_S_PYTHON_DLMODULES)/ecacontrol.py
+ endif
+ if ECA_AM_PYECASOUND_CEXT
+-pyecasound_install_list2 = pyecasound.so
++pyecasound_install_list2 = .libs/pyecasound.so
+ pyecasound_uninstall_list2 = $(DESTDIR)$(ECA_S_PYTHON_DLMODULES)/pyecasound.so
+ endif
+