summaryrefslogtreecommitdiff
path: root/media-sound/exaile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-sound/exaile
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/Manifest3
-rw-r--r--media-sound/exaile/exaile-4.1.1-r1.ebuild72
-rw-r--r--media-sound/exaile/exaile-9999.ebuild18
3 files changed, 83 insertions, 10 deletions
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
index 68fb6124caf2..6eb13d03ed19 100644
--- a/media-sound/exaile/Manifest
+++ b/media-sound/exaile/Manifest
@@ -1,5 +1,6 @@
AUX exaile-4.1.1-metainfo.patch 1472 BLAKE2B 5c466aa63e8fc4538d53f07fcb5c943bbabfb1f4a7b1037b13f013c3cb9286470ae56007e35772ad015863b0debf684f85fa56e1ba664ac2f2ca5a1afc50936b SHA512 80b642e037335706b24ec907bc7d50e2cfb9505c18bed33deecb7d8aa282d6fbdb9ac1272e49f561a99593e498c5b84ea9298297095910950ef5c0208288120e
DIST exaile-4.1.1.tar.gz 3641073 BLAKE2B 34222ddba782dd51897c017d7a77da9a796e45dad69983f934e76cc559c2e52f2173ee418004943ca087fd894439bc42a6eff2a5d6146e6189ec1cd478f5d08b SHA512 babf37253054fbeb6dad33aedafe969201860d4f35222d577343256730be943682c1a5f2f7cec7c574695624cb2b7abbdff4e6eaada848d22fea073c2c44bd23
+EBUILD exaile-4.1.1-r1.ebuild 1663 BLAKE2B 490eb0d3572540c2dcd8a0e2b1228eb1722fe46b26ab29213d415664ccfb98e3e3b7ab771c869084b7802af1a48a1a17373bf38840fdcbbdfab4c0a4210d83df SHA512 ae634ce670b814355358a61a2031f22571c7906e85d577bb73d624fcb2df6203041f3d5d84ee433e7f159c566284b1cbb9279159282f020b08f64a9444ccf3d6
EBUILD exaile-4.1.1.ebuild 1703 BLAKE2B b2dab1ea5dbb7188d1276c95d50cfe5b702f46c6854109f44e4320f27fe8d522e396abbc974e5cf3521c48d14821bc483ba25a71be80efdd63dda181efd7992c SHA512 3e6a8eebee581fb2d5bd25dd09e98fc1a412f4e14d39803e099db275501a5930f59abb3a5460d7588e86e2bc15cd3f382fc8f57c59e518066f734e05b8f04e56
-EBUILD exaile-9999.ebuild 1710 BLAKE2B 58b646c3cbbdaa1bd036dc003feec9489ed67d7f35235127334dc38cef5c23af100c7f0c6d864c05b4c6d64a4f8cd635d5475aa6fb46580d9039546147099c3e SHA512 5977d8d627fdc9c20b0d4219f2e19f9d3d8de6823f42fec0b1f04b41503aa17f4e719b7c83227be51b666479ea36bcab464a5ae93002e89d95fd1a8b8c2d78ae
+EBUILD exaile-9999.ebuild 1670 BLAKE2B b1c52f10c2111f15a124d2a5eaee505b3a7c9faf45b1b41da1667707908a02f47255fa5b6fcf5175493fa192b9a6ae2e4b19f055220befe46b653f53ee55aed3 SHA512 c71a9e2afc4c6da2a7f054b69157dd42ccc9273f3c27fcd79672f6d5dd742583e00b442e7381a305ac917200e43193a0a55c22a8d2cd31a77bffbe6c296dfdb1
MISC metadata.xml 466 BLAKE2B 8c2ae9dfde18d1976a3c38a77de336e5f0489879adcdb030c9c6b3cb765e440d8bf908c57b2fe1670b090d90c570b3219201319d81319dda87c92c777c82757e SHA512 5bdedc04863ba9c8632a818d8f7a834687e3474cfe906b0ee82378f6c957ecc9778206f8b7f7abefda5cba06c4c0df930e5e170754fa8c59467dd4f1857be4f8
diff --git a/media-sound/exaile/exaile-4.1.1-r1.ebuild b/media-sound/exaile/exaile-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..a8ee142fac0e
--- /dev/null
+++ b/media-sound/exaile/exaile-4.1.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+# IUSE+=cddb if have dev-python/cddb-py
+IUSE="libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
+ ')
+"
+
+RESTRICT="test" #315589
+
+PATCHES=(
+ "${FILESDIR}/${P}-metainfo.patch"
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}
diff --git a/media-sound/exaile/exaile-9999.ebuild b/media-sound/exaile/exaile-9999.ebuild
index 93bda21f7a3e..36c7f3272d08 100644
--- a/media-sound/exaile/exaile-9999.ebuild
+++ b/media-sound/exaile/exaile-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1 xdg
if [[ ${PV} == "9999" ]]; then
@@ -30,18 +30,18 @@ BDEPEND="
)
"
RDEPEND="${PYTHON_DEPS}
- >=media-libs/gst-plugins-base-1.6:1.0
- >=media-libs/gst-plugins-good-1.4:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
media-plugins/gst-plugins-meta:1.0
- >=x11-libs/gtk+-3.10:3[introspection]
- libnotify? ( >=x11-libs/libnotify-0.7[introspection] )
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
$(python_gen_cond_dep '
dev-python/bsddb3[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/gst-python:1.0[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.13.2:3[${PYTHON_USEDEP}]
- >=media-libs/mutagen-1.10[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
')
"