summaryrefslogtreecommitdiff
path: root/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 03:08:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 03:08:54 +0100
commitcdb747b791914a30c287a3a8e33d1b635e431707 (patch)
treebe22ab4ebfae7f170acb577486d0edc7e6d14279 /media-sound/ezstream/ezstream-0.6.0-r2.ebuild
parent496936ff0f7db69d1f7317341230acb866e3c330 (diff)
gentoo auto-resync : 30:07:2022 - 03:08:54
Diffstat (limited to 'media-sound/ezstream/ezstream-0.6.0-r2.ebuild')
-rw-r--r--media-sound/ezstream/ezstream-0.6.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/ezstream/ezstream-0.6.0-r2.ebuild b/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..d9cb6fb09888
--- /dev/null
+++ b/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A command line source client for Icecast media streaming servers"
+HOMEPAGE="https://www.icecast.org/ezstream/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="taglib"
+
+DEPEND="
+ dev-libs/libxml2
+ >=media-libs/libshout-2.2
+ !taglib? ( media-libs/libvorbis )
+ taglib? ( media-libs/taglib )"
+RDEPEND="
+ ${DEPEND}
+ net-misc/icecast"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-examplesdir='$(docdir)/examples' \
+ $(use_with taglib taglib "${ESYSROOT}"/usr)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ rm -f "${ED}"/usr/share/doc/${PF}/COPYING || die
+}