summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
commit02930d1eb5af78d32b1597af6af24163895d9e0f (patch)
tree7908188ca5a80d7ff557ebc70fe3bdcbf2875832 /media-sound/fluidsynth
parent54654470d999265b5a0010be7190e8a9993b1840 (diff)
gentoo auto-resync : 11:05:2023 - 23:47:37
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/files/2.3.2-musl-implicit-declaration-fix.patch34
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.2-r1.ebuild123
3 files changed, 159 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 0220190bd992..c187e098878f 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,5 +1,7 @@
+AUX 2.3.2-musl-implicit-declaration-fix.patch 991 BLAKE2B 519b679a16f547b590ba64ec4f045c4e7570f15c59eadfd31072913218c118e3253e7bd35c5854c4878e1288921fabe11897504a42642d3b3ce698fbaa1fbb32 SHA512 cda4b24e0959c4578d192f8708eedb75469141c906276a3fc088971bd0689900d54b18f2059815479080a0a44c6befa5a56e703d2f55ab113f5f5c28617f7236
DIST fluidsynth-2.3.1.tar.gz 1758632 BLAKE2B a1501303e02b3ea64d87be5cff08d5f2f2be170b38faedc8e6bc4fd18c0dafe268fa6110708664ef0659df9f0e9680551ac483d30364977e768af60dfdff7e83 SHA512 1633294bf6c714361c381151b62d9dd2c8f388490153e7964bfa14fd647a681db9ebfe1de0a06279972d6c5b30377f67361feb4db186b1faa235600f0ae02b22
DIST fluidsynth-2.3.2.tar.gz 1773755 BLAKE2B 2d88e52223ff9c6bc5bcbcd8b15f30abb12632202b9a5c5eecc5eb95620aeaa2d7d9b80b76e6b26eef95ca92521bdc9e6d539f8235d90ca0429b12bb72db1a6f SHA512 21798b5a80a7edd8ef02b983d9b230af45cc66b98b32d593228e12dbec15b12c6cf6c0f3692c12af66de1ba2049fa9d6ad2b68c7d1579347eec14d24870b0025
EBUILD fluidsynth-2.3.1.ebuild 3452 BLAKE2B ad87e841d41bace7720904372f33ec26da9685a68e8ac6849db841e3c73606c9335d885ac8ceb629b98ef83c806f032dc284441bc8caa7b83bc30924193f4dd5 SHA512 ac76893a9282bea3dbbaa5299dfc3e3a3f1fbb2660f69b298f09a504317a303c4ea9b6416d13493339a04b9c2a650b82a644cd0bf01144133f0913d4c3b13ad1
+EBUILD fluidsynth-2.3.2-r1.ebuild 3528 BLAKE2B 5aaf7c44af39337a47732ba0216131ee045d531465ca77adcf43f1a5b6fc67fe4cf9c0652d93afa1b5a08421f91773e076b493b7b962d7a680e909c742cd36a5 SHA512 604e4e76e1068b3a3dbc6807d6c4df469df06240077687ae6afcda5e2f5fcd073b4cbb3e94674b5114d059f5a4827b6715279a1480b591b2505d5e30e797fa2c
EBUILD fluidsynth-2.3.2.ebuild 3454 BLAKE2B 629018f4cb334ad7963932f848e6eca273d9294321b732aa5c7a581d506c4ba83d201bcc9b30a1921c32751ccb67b2162b2dfe19830e8885cc7590bae76d00cd SHA512 ffe40ef484ed6f0fc578c29926f624e9c6e973dcb064be8295b2a6dbb329ecf57f2a9cf17d20696d9976114b8a7fed4ad4205c61d2b52c4e1ed364ca675dcb22
MISC metadata.xml 509 BLAKE2B f94b91d9486a14757aa47e69269d6321fb330556f24ac0d2d47d7734bc28164d9cff5d7ff7728aa6d59606006bc4bfa090662b9dd087a6bf36ae23660604938a SHA512 7bf5aeb69570ef736dc6a1a3d652449b0142978ee5e6ed9902d4f851deea87c8fb94bee821ee9ae93bc529411f336288021718490e86c2815de5d30111bd3b28
diff --git a/media-sound/fluidsynth/files/2.3.2-musl-implicit-declaration-fix.patch b/media-sound/fluidsynth/files/2.3.2-musl-implicit-declaration-fix.patch
new file mode 100644
index 000000000000..ae53ad240979
--- /dev/null
+++ b/media-sound/fluidsynth/files/2.3.2-musl-implicit-declaration-fix.patch
@@ -0,0 +1,34 @@
+https://github.com/FluidSynth/fluidsynth/pull/1244
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Thu, 11 May 2023 23:14:42 +0530
+Subject: [PATCH] Fix implicit declaration of function strcasecmp with musl
+
+This will also help in making the source code c99 compilant, thus
+helping in packaing for newer compilers (for example clang 16 and gcc 14)
+
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -159,6 +159,7 @@ include ( CheckIncludeFile )
+ include ( CheckSymbolExists )
+ include ( CheckTypeSize )
+ check_include_file ( string.h HAVE_STRING_H )
++check_include_file ( strings.h HAVE_STRINGS_H )
+ check_include_file ( stdlib.h HAVE_STDLIB_H )
+ check_include_file ( stdio.h HAVE_STDIO_H )
+ check_include_file ( math.h HAVE_MATH_H )
+--- a/src/utils/fluidsynth_priv.h
++++ b/src/utils/fluidsynth_priv.h
+@@ -45,6 +45,9 @@
+ #include <string.h>
+ #endif
+
++#if HAVE_STRINGS_H
++#include <strings.h>
++#endif
+
+ #include "fluidsynth.h"
+
+--
+2.40.1
+
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.2-r1.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..de5c7306eba0
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.3.2-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib systemd toolchain-funcs
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ pipewire? (
+ media-video/pipewire:0=[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+PATCHES=( "${FILESDIR}/${PV}-musl-implicit-declaration-fix.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_C_COMPILER="$(tc-getCC)"
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-pipewire=$(usex pipewire)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}