summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /media-sound/fluidsynth
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.2.1.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index e93ef6f2b5f4..305eb6bcf370 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,5 @@
DIST fluidsynth-2.2.0.tar.gz 1507709 BLAKE2B 4ec162ecf461f3fbc80d1b5c1a4bc0624d8274dedcfa32addfd79d7270811e532bccee46b90181bca504183e092176652f6c9d0ae8eccfb5617b9176b8bc511e SHA512 fa08c6d6914accbb5a99bb912066d97ded26ab3c706e663e76a4f1b024f610f676d2e1f7c30872d00e0fe86b5c494dcea581ecd0770977d235962a845c074bd6
+DIST fluidsynth-2.2.1.tar.gz 1594153 BLAKE2B 9a297859ae90e3dba21a3923059c081596d2a5ff107219b829f75e2067bea315364c9b4a9a4e6563c5a9f9ded92efff2c58d1aef9840b308fe69f546797c83ae SHA512 a42728f179fd2583a292d18d9b7d98498b42574aff6559e8e3762329893dd18c451b5611517aa9aa7ee6ba9fc0db3c83e127d097c68769c5d8562a49dc427ee9
EBUILD fluidsynth-2.2.0-r1.ebuild 3314 BLAKE2B 1170bc2979a36dcbe5b84ca2ef8e4c34256c9da3514833bd23d1e0edd7753f876a943be534630a8ec0637024ca0a4a34ec06bcf83a42ee4f3f0948cd716cf29b SHA512 6de4ee1f429768af858bc9bedf365e4977ef8f2d04a815ba0fb6c5649b2989c56bb56951cd1647e3c6f3a1a93d1daf99783532aa4e32512db4273df4091b235f
+EBUILD fluidsynth-2.2.1.ebuild 3321 BLAKE2B bb22fcff64287a4d5e9ac3a56821627974fb6c65aa252ebf935c9243e49d3bbd858ee7847c1797892ac8f3c02541e880a677801baeb51b089064ce89c3b01265 SHA512 3fd862663ab056ffb93a46b297f505958384e33aa786110cbcb63574bf3dded6aee123f98edeff2cc625a00fdf7f72b29048a33a1fb466d9fbccfd9de1cf163a
MISC metadata.xml 430 BLAKE2B cef06a37f27e4ef3a555000188873f0f36a89dc90a3576dc15fb384a8f3c8f5bd38ccb79f56704ec7031823d3057eda17ac975a3ea1e265133e5ff81afc141d8 SHA512 c702d31a98e905d95f95f6cdfc16d8a71de5a5a55628e59e56d408a6599cdf6ab005642ee064217d88e0061c2856692e1446e340a3e80f2bc17ed1d3c2a14e9a
diff --git a/media-sound/fluidsynth/fluidsynth-2.2.1.ebuild b/media-sound/fluidsynth/fluidsynth-2.2.1.ebuild
new file mode 100644
index 000000000000..781c4e52a80f
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.2.1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib systemd
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-debug=$(usex debug)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-pkgconfig=ON
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}