summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-30 13:14:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-30 13:14:10 +0000
commitbe3b27c21c5761f8ff9688e4d468045abaddb9c4 (patch)
treedda69b93e438e718aefefc19b5393aae50a650cd /media-sound/fluidsynth
parent170de61465af51be213eb93e0da4077f06fe7506 (diff)
gentoo auto-resync : 30:03:2024 - 13:14:10
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.5.ebuild149
2 files changed, 151 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 29b2b835a1c3..49391400de14 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,5 @@
DIST fluidsynth-2.3.4.tar.gz 1775291 BLAKE2B 5146c1f0243ac1fcc3d4f29ea65bb03b326c59bf9de1f53def447f4a924c7fdde31f8b33300051d2e7765087fb8bbdba3643b03c537e3366b02ca42b3b9d4311 SHA512 79891116d78b9be1c38bce9e5759b9bb732c3d8ee31c6e57d1a3e2b5548879b91d19582e73ee7fb0fd243beba3bf1bbc341a26aab0b6440eef36fc55dce3e8b0
+DIST fluidsynth-2.3.5.tar.gz 1775448 BLAKE2B 11f04d2a508f54c4bd03c867e81528f36eeb5698ad017d7fe778349b5ab91dc9e518d426d2394e748344795b8c1bf86eeaee97294ad66974db07587d0a80797a SHA512 35eaea8c1709ebbd5dee8f3946ab59c39afe31d92b972a44013fa23987aa48936f7d1326d5bda81c6e66f02bf988e48601367d49276a4dd78dbca7a2571f5e57
EBUILD fluidsynth-2.3.4-r1.ebuild 4017 BLAKE2B 12a779cdbca3bcb05c428d57a9f063634cc72870f0baf954096af7b3235ea284d0971054e0721194570a28777172ac4bd49b657882182569fe12a01a5c85d3fb SHA512 f83ce5a5250de7153e4407878ba1af8baf46ded702a009b75ecebb0c352ac6530891e73f38bfe89975d0abef5d973c73f0d58d20d49b21a3359afff4d036c78f
+EBUILD fluidsynth-2.3.5.ebuild 4024 BLAKE2B 78d6321b7184fa8ed7323d93f246d3c308ae1d31e7de6898234a96e7c75e9670eb737c3e73615d5de4544bff71c567e47e09c2f4e5dc4f6f06936f7378484995 SHA512 e26780e755275b83f553d49e0ca0018d8cd1ef9c041a4eff1314d24cf863ac4d2749ad5af4d75ac42f9360a184320a2a9a4d9197f8676fac87f47133d7f2aadc
MISC metadata.xml 509 BLAKE2B f94b91d9486a14757aa47e69269d6321fb330556f24ac0d2d47d7734bc28164d9cff5d7ff7728aa6d59606006bc4bfa090662b9dd087a6bf36ae23660604938a SHA512 7bf5aeb69570ef736dc6a1a3d652449b0142978ee5e6ed9902d4f851deea87c8fb94bee821ee9ae93bc529411f336288021718490e86c2815de5d30111bd3b28
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.5.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.5.ebuild
new file mode 100644
index 000000000000..6a33c564f64d
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.3.5.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib multibuild systemd toolchain-funcs
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa dbus debug doc ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-libs/libxslt
+ )
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ pipewire? (
+ media-video/pipewire:0=[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-libs/libpulse[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+src_prepare() {
+ # https://bugs.gentoo.org/833979#c17
+ sed -i "/CONFIGURE_COMMAND/{n;s/$/ -DCMAKE_C_COMPILER=$(tc-getBUILD_CC)/}" \
+ src/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=OFF # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-pipewire=$(usex pipewire)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ $(cmake_use_find_package doc Doxygen)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+compile_doxygen_doc() {
+ multilib_is_native_abi && cmake_build doxygen
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+ use doc && multilib_foreach_abi compile_doxygen_doc
+}
+
+install_doxygen_doc() {
+ if multilib_is_native_abi; then
+ docinto .
+ dodoc -r "${BUILD_DIR}/doc/api/html"
+ fi
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ docinto examples
+ dodoc doc/examples/*.c
+
+ if use doc; then
+ multilib_foreach_abi install_doxygen_doc
+ fi
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}