summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-11 07:29:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-11 07:29:23 +0100
commitfbe1e64cf651fcf73e25d2d3115003bf59e231cd (patch)
tree5077c9b46dc8e389d2fc7dc7c77c819425e6203b /media-sound/fluidsynth
parentb46b9834b3fbf80b22ccc12e95f660512cd0fa75 (diff)
gentoo auto-resync : 11:07:2022 - 07:29:23
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.2.8.ebuild120
2 files changed, 122 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index cc4534a35a45..99791d15f290 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,5 @@
DIST fluidsynth-2.2.7.tar.gz 1748897 BLAKE2B fd53603947ddf5a76676cfc3d77b1d904146ec7c30ab6e54a2c32cae0e76ec4b66397506072cac277febdd1b799801d5b13c7b37cc0ea4a545fae26077a1d881 SHA512 62709f96fa07bbafb9b907438da7376abdf1a4e679cd2b105c5bca257f1ff62c18bd4c646ef2ccba64ca5273604da996fb2caaf61eeee44686bf45fef1ed83a7
+DIST fluidsynth-2.2.8.tar.gz 1751615 BLAKE2B 7eaee4cc1c2f49e464cda2852890ec8e96bd86c258a39246ec5c84ea3e57c9869d1e88963daecc3fa8957df1d55ff6c6633a4900de3d6fc0a1adf830865adda0 SHA512 8173f2d368a214cf1eb7faae2f6326db43fb094ec9c83e652f953290c3f29c34ebd0b92cbb439bea8d814d3a7e4f9dc0c18c648df1d414989d5d8b4700c79535
EBUILD fluidsynth-2.2.7.ebuild 3411 BLAKE2B cf562d000e5f356f19726938c25725b46fafb5e89cf38284f06b22698c8b862223d36a50aca668442646883ec9f276233388c6ead9bd1e4552960e7f1297c8c3 SHA512 005178c5da24a8d97d75743235db5ea4dd6c7f08896b06af3dca8ee14f0b8acd05009ba28f0a5fa7c40a0507d7b9bb164117b92ceb00d3574eb8345ccab33dfc
+EBUILD fluidsynth-2.2.8.ebuild 3418 BLAKE2B d06ccfb0efd1626bf3ad273d7b743fc549a1a4d7d8f1bfb24dfbb303e2141370510d9326b34912995bd5604c4824fb7293919e98faeae7a57af69caf29e731c1 SHA512 c401e9ab73e94457be436e4adf6a0c438000743da19a57e299e5e6844ec1bea8ef294f9a4428186601b5c1b33be9b245d0a851055d4d41f1699d3a1214026ee2
MISC metadata.xml 431 BLAKE2B f739f538274e2e63b1977673b0766a594db59982ab71d6552d1e841434c4040bb7af29d441b1d9e8ce61385dbdb8e522b5591f6826a4c52f085bf004f9fe8426 SHA512 c8085e7652a504610fb841e302ee380de58a67a16a9b874447c00ee20c2d56119254eed954704e8bd4cf8e574980da2dd2f90baa5c99e59cd534e26245af67bb
diff --git a/media-sound/fluidsynth/fluidsynth-2.2.8.ebuild b/media-sound/fluidsynth/fluidsynth-2.2.8.ebuild
new file mode 100644
index 000000000000..51908c546139
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.2.8.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib systemd toolchain-funcs
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_C_COMPILER="$(tc-getCC)"
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-debug=$(usex debug)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-pkgconfig=ON
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}