summaryrefslogtreecommitdiff
path: root/media-sound/gnomad/gnomad-2.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/gnomad/gnomad-2.9.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/gnomad/gnomad-2.9.6.ebuild')
-rw-r--r--media-sound/gnomad/gnomad-2.9.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/gnomad/gnomad-2.9.6.ebuild b/media-sound/gnomad/gnomad-2.9.6.ebuild
new file mode 100644
index 000000000000..14e8e6ce2e86
--- /dev/null
+++ b/media-sound/gnomad/gnomad-2.9.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A GTK+ music manager and swiss army knife for the Portable Digital Entertainment (PDE) protocol"
+HOMEPAGE="http://gnomad2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libid3tag
+ media-libs/libmtp
+ media-libs/libnjb
+ media-libs/taglib
+ >=x11-libs/gtk+-2.24:2
+ virtual/libgudev:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS README TODO ) # ChangeLog and NEWS are both outdated
+
+src_configure() {
+ econf $(use_enable nls)
+}