summaryrefslogtreecommitdiff
path: root/media-sound/grip/grip-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/grip/grip-4.2.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/grip/grip-4.2.0.ebuild')
-rw-r--r--media-sound/grip/grip-4.2.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/grip/grip-4.2.0.ebuild b/media-sound/grip/grip-4.2.0.ebuild
new file mode 100644
index 000000000000..c3d4c46b1204
--- /dev/null
+++ b/media-sound/grip/grip-4.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils flag-o-matic toolchain-funcs libtool xdg
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}