summaryrefslogtreecommitdiff
path: root/media-sound/gtick/gtick-0.5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /media-sound/gtick/gtick-0.5.4.ebuild
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'media-sound/gtick/gtick-0.5.4.ebuild')
-rw-r--r--media-sound/gtick/gtick-0.5.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-sound/gtick/gtick-0.5.4.ebuild b/media-sound/gtick/gtick-0.5.4.ebuild
new file mode 100644
index 000000000000..6d5842684e83
--- /dev/null
+++ b/media-sound/gtick/gtick-0.5.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Metronome application supporting different meters and speeds ranging"
+HOMEPAGE="https://www.antcom.de/gtick"
+SRC_URI="https://www.antcom.de/gtick/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls sndfile"
+
+RDEPEND="x11-libs/gtk+:2
+ media-sound/pulseaudio
+ sndfile? ( media-libs/libsndfile )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i "/GenericName/d" ${PN}.desktop || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with sndfile)
+}
+
+src_install() {
+ default
+ newicon src/icon48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "GTick"
+}