summaryrefslogtreecommitdiff
path: root/media-sound/lash/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /media-sound/lash/files
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'media-sound/lash/files')
-rw-r--r--media-sound/lash/files/lash-0.5.4-autotools.patch32
-rw-r--r--media-sound/lash/files/lash-0.5.4-c99.patch11
2 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/lash/files/lash-0.5.4-autotools.patch b/media-sound/lash/files/lash-0.5.4-autotools.patch
new file mode 100644
index 000000000000..54988c70bbc7
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-autotools.patch
@@ -0,0 +1,32 @@
+Fix build with modern autoconf/automake and fix a bashism in configure.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,3 +1,5 @@
++ACLOCAL_AMFLAGS = -I m4
++
+ SUBDIRS = m4 docs lash liblash lashd clients icons pylash
+
+ pkgconfigdir = $(libdir)/pkgconfig
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,7 +2,6 @@ AC_INIT([LASH],[0.5.4])
+ AC_CONFIG_SRCDIR([lash/types.h])
+ AC_CONFIG_HEADER([config.h])
+ AM_INIT_AUTOMAKE
+-AM_ACLOCAL_INCLUDE([m4])
+
+ ### Check for programs ###
+ AC_LANG([C])
+@@ -161,10 +160,10 @@ AC_ARG_ENABLE(pylash, [AS_HELP_STRING(--disable-pylash, [Force disable pylash bu
+ if test x$build_pylash != xdisabled; then
+ AM_PATH_PYTHON(2.3, python_found=yes, python_found=no)
+
+- if test x$python_found == xyes; then
++ if test x$python_found = xyes; then
+ AM_CHECK_PYTHON_HEADERS(, python_found=no)
+
+- if test x$python_found == xyes; then
++ if test x$python_found = xyes; then
+ AC_PROG_SWIG(1.3.31)
+ if test "$SWIG_LIB" ; then
+ build_pylash=yes
diff --git a/media-sound/lash/files/lash-0.5.4-c99.patch b/media-sound/lash/files/lash-0.5.4-c99.patch
new file mode 100644
index 000000000000..31dab715db7e
--- /dev/null
+++ b/media-sound/lash/files/lash-0.5.4-c99.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/925439
+--- a/clients/synth/lash.c
++++ b/clients/synth/lash.c
+@@ -22,6 +22,7 @@
+
+ #include "config.h"
+
++#include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+