summaryrefslogtreecommitdiff
path: root/media-sound/linux-show-player
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
commitbf99f8024d68382f76665735c70ae912331bc2ca (patch)
tree6fa5830f88fa9ddb794b019c25b83a76ec410df4 /media-sound/linux-show-player
parentc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (diff)
gentoo auto-resync : 04:10:2022 - 07:16:51
Diffstat (limited to 'media-sound/linux-show-player')
-rw-r--r--media-sound/linux-show-player/Manifest3
-rw-r--r--media-sound/linux-show-player/linux-show-player-0.5.3.ebuild45
-rw-r--r--media-sound/linux-show-player/metadata.xml15
3 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/linux-show-player/Manifest b/media-sound/linux-show-player/Manifest
new file mode 100644
index 000000000000..deeb6959e92a
--- /dev/null
+++ b/media-sound/linux-show-player/Manifest
@@ -0,0 +1,3 @@
+DIST linux-show-player-0.5.3.tar.gz 1080409 BLAKE2B 8292263965434587b0086c6505167a1a3dbe82593a07a7c26855136f8c330ffd1c16ecd1e7e758af7e07731df7db79a66743297d22594d9332025e73a7990c34 SHA512 f60f65c045fb57c2c2e5f2daf6b225115a0f4fef173869e971741f2e40b71931b88e56c2343c348701784449d1f032219d307cdb7bb31d6283ea2b0c816d0286
+EBUILD linux-show-player-0.5.3.ebuild 1217 BLAKE2B 5403b60aebbc230fce86c9c88c18721f533a62269c8fbb458006479d89fb25acba9e09ff92dd9768abb0255846913945dc66f957f8590b0e41a19791afd2b30c SHA512 ba96b01162cfe8568e4acc194a16b216505713b413d8a4c02e945bb513c5fb413e41fc120f2f15d8946579c1b2052f905cdd502e69f510bd903f036c85b2383e
+MISC metadata.xml 459 BLAKE2B 010b210d72b6c76a26dd282bab86ef9d56964eb38b15bbb025b9cc16cb1ea9d5905436b3799f682af2cf460a0d8717633f88957b636dd2064e16685abee67aab SHA512 00484a5623c689205a6c1354d46dd6ed28c62af3cac99c429c1d931ba04112750067551360ff61332ddc773deccb09d42a7f18d15fbedf834d39016c221583ef
diff --git a/media-sound/linux-show-player/linux-show-player-0.5.3.ebuild b/media-sound/linux-show-player/linux-show-player-0.5.3.ebuild
new file mode 100644
index 000000000000..975dbeaa2462
--- /dev/null
+++ b/media-sound/linux-show-player/linux-show-player-0.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A cue player designed for stage productions"
+HOMEPAGE="https://www.linux-show-player.org/ https://github.com/FrancescoCeruti/linux-show-player/"
+SRC_URI="https://github.com/FrancescoCeruti/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa jack midi pulseaudio"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+ ')
+ media-libs/gstreamer[introspection]
+ alsa? ( media-libs/gst-plugins-base[alsa] )
+ jack? (
+ $(python_gen_cond_dep '
+ dev-python/jack-client[${PYTHON_USEDEP}]
+ ')
+ media-plugins/gst-plugins-jack
+ )
+ midi? (
+ $(python_gen_cond_dep '
+ dev-python/mido[${PYTHON_USEDEP}]
+ ')
+ )
+ pulseaudio? ( media-plugins/gst-plugins-pulse )
+"
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "${PN} uses GStreamer as its audio back-end so make sure you have plug-ins installed for all the audio formats you want to use"
+ fi
+}
diff --git a/media-sound/linux-show-player/metadata.xml b/media-sound/linux-show-player/metadata.xml
new file mode 100644
index 000000000000..62f26b37b07f
--- /dev/null
+++ b/media-sound/linux-show-player/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">FrancescoCeruti/linux-show-player</remote-id>
+ </upstream>
+ <use>
+ <flag name="midi">Allow cues to send, or trigger on, MIDI messages</flag>
+ </use>
+</pkgmetadata>