summaryrefslogtreecommitdiff
path: root/media-sound/lmms/lmms-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-sound/lmms/lmms-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-sound/lmms/lmms-9999.ebuild')
-rw-r--r--media-sound/lmms/lmms-9999.ebuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index a92a923b07b8..2650aa8061a8 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# The order is important here! Both, cmake and xdg define src_prepare.
# We need the one from cmake
-inherit xdg cmake
+inherit bash-completion-r1 xdg cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -70,6 +70,7 @@ DOCS=( README.md doc/AUTHORS )
src_configure() {
local mycmakeargs+=(
+ -DBASHCOMP_PKG_PATH="$(get_bashcompdir)"
-DUSE_WERROR=FALSE
-DWANT_CAPS=FALSE
-DWANT_TAP=FALSE
@@ -92,15 +93,3 @@ src_configure() {
)
cmake_src_configure
}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
-}