summaryrefslogtreecommitdiff
path: root/media-sound/lollypop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
commit7051f2e58b6bbc371b2c94cead2715bf06310adb (patch)
treed8eb7cbcdfa3883fcdb1cb004774e17be52600b0 /media-sound/lollypop
parent3b4acc0bc0b77136b371d8a3119066f80f221efe (diff)
gentoo auto-resync : 11:01:2023 - 23:45:17
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest2
-rw-r--r--media-sound/lollypop/lollypop-1.4.35.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 586dd3b5c32b..b1049f893480 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,3 +1,5 @@
DIST lollypop-1.4.29.tar.xz 593980 BLAKE2B 8a3a985cb18c196665377c7c29670b98f352a86284ee8bb5af13b1017346b0b2b938dee6e53d56d0b8d98b191a64e5efd1c7126879c7017c3f10d5aa96570a39 SHA512 f81315a94cbcc726cd453d58faffe5c33ebcbdaef55a5a36d2a9dc20dec9340c2d263d935b5115148b049fca52e57c88eac36386e56f0965f22674eba26ae813
+DIST lollypop-1.4.35.tar.xz 596016 BLAKE2B 6776d98d8d0da18dade3ac022ea7980e9762834ebaadae453abb0dd0f0d98298f2457d2cb18f21159e2d12d4735d3c87740b0449a090f7778b7d77ba82634e40 SHA512 8cde0db23dd011370fbcf2a32389f801d7586598bb653b921f4525af17e2eb4771a306e34a340bb8c4a1666727c4b1c3a84490f362ca3c473fb7c5b3982a644d
EBUILD lollypop-1.4.29.ebuild 1404 BLAKE2B 02237dfbd2e5e43fee563919509e80728c81d90ea76b287d8603b0b6ad3fac02271107e9e5c2a7a26a8dfc31531b8113d59ed537f41e709c26081325e442a5ac SHA512 ebd7412582861f64cef259527ce0a27a0f4cd0709783be3f4387127796d3e8974acf0b9838ebfe32606c3916e5a37f2e183e835a2bda055b1792a5707c63f891
+EBUILD lollypop-1.4.35.ebuild 1599 BLAKE2B f60d938b7c1e7392a57d2ffd180b231c06e911f2de3bc321c7f246d40ba14b60729204de49de5199fce9e2859b0e9d31a437b060238d42c1ed4f4e2241185334 SHA512 a4c40a02e7df0775b71d8e68b6ce8dfbd424e1674327fc6cf48a86f7c9f3d72e1b3848f0fcafe682cc8fe336a5acb9fb694a17aee9f92e3a0974446666089a8a
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/media-sound/lollypop/lollypop-1.4.35.ebuild b/media-sound/lollypop/lollypop-1.4.35.ebuild
new file mode 100644
index 000000000000..e8b553c2953e
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.35.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# Dependencies being checked by Meson
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/gtk+:3[introspection]
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-plugins/gst-plugins-pulse
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser[introspection]
+ gui-libs/libhandy:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ elog "Remember to install the necessary gst-plugins packages to read your audio files"
+ elog "You can also use the gst-plugins-meta pakcage and its USE flags."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}