summaryrefslogtreecommitdiff
path: root/media-sound/marrie/marrie-0.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/marrie/marrie-0.3.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/marrie/marrie-0.3.2-r1.ebuild')
-rw-r--r--media-sound/marrie/marrie-0.3.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/marrie/marrie-0.3.2-r1.ebuild b/media-sound/marrie/marrie-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..c44c712b03f4
--- /dev/null
+++ b/media-sound/marrie/marrie-0.3.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+GIT_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
+fi
+
+inherit distutils-r1 ${GIT_ECLASS}
+
+DESCRIPTION="A simple podcast client that runs on the Command Line Interface"
+HOMEPAGE="https://github.com/rafaelmartins/marrie"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/setuptools
+ >=dev-python/feedparser-5.1.3"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ rst2html.py README.rst marrie.html || die "rst2html.py failed"
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ if use doc; then
+ dohtml marrie.html
+ fi
+}
+
+pkg_postinst() {
+ distutils-r1_pkg_postinst
+ elog
+ elog "You'll need a media player and a file downloader."
+ elog "Recommended packages: net-misc/wget and media-video/mplayer"
+ elog
+}