summaryrefslogtreecommitdiff
path: root/media-sound/mmix/mmix-0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /media-sound/mmix/mmix-0.3-r1.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'media-sound/mmix/mmix-0.3-r1.ebuild')
-rw-r--r--media-sound/mmix/mmix-0.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mmix/mmix-0.3-r1.ebuild b/media-sound/mmix/mmix-0.3-r1.ebuild
new file mode 100644
index 000000000000..f00dba606ab5
--- /dev/null
+++ b/media-sound/mmix/mmix-0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A soundcard mixer for the OSS driver"
+HOMEPAGE="http://www.mcmilk.de/projects/mmix/"
+SRC_URI="http://www.mcmilk.de/projects/${PN}/dl/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# media-sound/mmix and dev-lang/mmix both install 'mmix' binary, bug #426874
+RDEPEND=""
+DEPEND="virtual/os-headers"
+
+src_prepare() {
+ default
+ sed -i -e '/strip/d' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman doc/${PN}.1
+ dodoc doc/{AUTHORS,CHANGES,FAQ,README}
+}