summaryrefslogtreecommitdiff
path: root/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild')
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
index b1c4d173eeb6..467241065e7c 100644
--- a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
MY_PV="${PV}-1" # Patchlevel
@@ -14,19 +14,15 @@ SRC_URI="mirror://sourceforge/mp3asm/${PN}-${MY_PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-
-DEPEND=""
# the author uses weird numbering...
-S="${WORKDIR}/mp3asm-0.1"
+S="${WORKDIR}/${PN}-0.1"
src_compile() {
- econf || die "econf failed"
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
- dobin src/mp3asm || die "install failed"
+ dobin src/mp3asm
dodoc Changelog README
}