summaryrefslogtreecommitdiff
path: root/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild')
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..8548f778919c
--- /dev/null
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+MY_PV="${PV}-1" # Patchlevel
+
+DESCRIPTION="A command line tool to clean and edit mp3 files"
+HOMEPAGE="https://sourceforge.net/projects/mp3asm/"
+SRC_URI="mirror://sourceforge/mp3asm/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+
+# the author uses weird numbering...
+S="${WORKDIR}/mp3asm-0.1"
+
+src_compile() {
+ econf || die "econf failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin src/mp3asm || die "install failed"
+ dodoc Changelog README
+}