summaryrefslogtreecommitdiff
path: root/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 13:27:08 +0100
commitbfc2a8298cab03d289dc2cfed63308396fa0babe (patch)
tree2d4288572b0938dcfc64edd39a4c1086402931a5 /media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild
parente28a6e6eb5373071be3a09aa457f0488d753c80c (diff)
gentoo auto-resync : 24:06:2023 - 13:27:08
Diffstat (limited to 'media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild')
-rw-r--r--media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild b/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild
new file mode 100644
index 000000000000..5493bd5a1c4c
--- /dev/null
+++ b/media-sound/mpd-ynca/mpd-ynca-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="MPD client to control Yamaha AV receivers with YNCA (network control) support"
+HOMEPAGE="https://github.com/chewi/mpd-ynca"
+SRC_URI="https://github.com/chewi/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ acct-user/mpd
+ dev-libs/boost:=
+ media-libs/libmpdclient
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}