summaryrefslogtreecommitdiff
path: root/media-sound/mpdscribble/mpdscribble-0.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /media-sound/mpdscribble/mpdscribble-0.23.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'media-sound/mpdscribble/mpdscribble-0.23.ebuild')
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.23.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/mpdscribble/mpdscribble-0.23.ebuild b/media-sound/mpdscribble/mpdscribble-0.23.ebuild
new file mode 100644
index 000000000000..09a5937e6e1f
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.23.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="
+ https://www.musicpd.org/clients/mpdscribble/
+ https://github.com/MusicPlayerDaemon/mpdscribble
+"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libgcrypt:=
+ media-libs/libmpdclient
+ net-misc/curl
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23-Unconditionally-generate-systemd-unit-files.patch
+ "${FILESDIR}"/${PN}-0.23-Don-t-install-AUTHORS-COPYING-NEWS-README.rst.patch
+)
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ keepdir /var/cache/mpdscribble
+
+ systemd_dounit "${BUILD_DIR}"/systemd/system/"${PN}".service
+ systemd_douserunit "${BUILD_DIR}"/systemd/user/"${PN}".service
+}