summaryrefslogtreecommitdiff
path: root/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild')
-rw-r--r--media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild b/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
new file mode 100644
index 000000000000..4c3f4d17ba0c
--- /dev/null
+++ b/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/mps-youtube.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.org/project/mps-youtube/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pafy[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+ || ( media-video/mpv media-video/mplayer )
+"