summaryrefslogtreecommitdiff
path: root/media-sound/mumble/mumble-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /media-sound/mumble/mumble-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'media-sound/mumble/mumble-9999.ebuild')
-rw-r--r--media-sound/mumble/mumble-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/media-sound/mumble/mumble-9999.ebuild b/media-sound/mumble/mumble-9999.ebuild
index 6caa7e0e0b35..e75beaeaaecf 100644
--- a/media-sound/mumble/mumble-9999.ebuild
+++ b/media-sound/mumble/mumble-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit multilib desktop qmake-utils xdg-utils
+inherit desktop gnome2-utils qmake-utils xdg-utils
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -20,7 +20,7 @@ fi
LICENSE="BSD MIT"
SLOT="0"
-IUSE="+alsa +dbus debug g15 libressl +opus oss pch portaudio pulseaudio +rnnoise speech zeroconf"
+IUSE="+alsa +dbus debug g15 jack libressl +opus oss pch portaudio pulseaudio +rnnoise speech zeroconf"
RDEPEND="
dev-qt/qtcore:5
@@ -40,6 +40,7 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
dbus? ( dev-qt/qtdbus:5 )
g15? ( app-misc/g15daemon )
+ jack? ( virtual/jack )
!libressl? ( >=dev-libs/openssl-1.0.0b:0= )
libressl? ( dev-libs/libressl )
opus? ( >=media-libs/opus-1.0.1 )
@@ -50,6 +51,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}
>=dev-libs/boost-1.41.0
+ dev-qt/linguist-tools:5
virtual/pkgconfig
x11-base/xorg-proto
"
@@ -71,19 +73,17 @@ src_configure() {
$(myuse dbus)
$(usex debug 'symbols debug' release)
$(myuse g15)
+ $(usex jack '' no-jackaudio)
$(myuse opus)
$(myuse oss)
$(myuse portaudio)
+ $(myuse pulseaudio)
$(myuse rnnoise)
$(usex speech '' no-speechd)
$(usex zeroconf '' no-bonjour)
)
- if has_version '<=sys-devel/gcc-4.2'; then
- conf_add+=( no-pch )
- else
- use pch || conf_add+=( no-pch )
- fi
+ use pch || conf_add+=( no-pch )
eqmake5 "${S}/main.pro" -recursive \
CONFIG+="${conf_add[*]}" \
@@ -116,6 +116,7 @@ src_install() {
}
pkg_postinst() {
+ gnome2_icon_cache_update
xdg_desktop_database_update
echo
elog "Visit http://mumble.sourceforge.net/ for futher configuration instructions."
@@ -124,5 +125,6 @@ pkg_postinst() {
}
pkg_postrm() {
+ gnome2_icon_cache_update
xdg_desktop_database_update
}