summaryrefslogtreecommitdiff
path: root/media-sound/normalize/normalize-0.7.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/normalize/normalize-0.7.7-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/normalize/normalize-0.7.7-r1.ebuild')
-rw-r--r--media-sound/normalize/normalize-0.7.7-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/normalize/normalize-0.7.7-r1.ebuild b/media-sound/normalize/normalize-0.7.7-r1.ebuild
new file mode 100644
index 000000000000..29194b93ee44
--- /dev/null
+++ b/media-sound/normalize/normalize-0.7.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Audio file volume normalizer"
+HOMEPAGE="http://normalize.nongnu.org/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.bz2
+ https://dev.gentoo.org/~radhermit/distfiles/${P}-m4.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="audiofile mad nls userland_BSD"
+
+RDEPEND="mad? ( media-libs/libmad )
+ audiofile? ( >=media-libs/audiofile-0.3.1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )"
+
+src_prepare() {
+ use userland_BSD && sed -i -e 's/md5sum/md5/' "${S}"/test/*.sh
+
+ epatch "${FILESDIR}"/${P}-audiofile-pkgconfig.patch
+ epatch "${WORKDIR}"/${P}-m4.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with audiofile) \
+ $(use_with mad) \
+ $(use_enable nls) \
+ --disable-xmms
+}