summaryrefslogtreecommitdiff
path: root/media-sound/pamix/pamix-1.6-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
commit662f71ae67cd775d7fbb79b5091676c0e07a992b (patch)
tree74c7cb80b79b8886cd7466cf262878d1e8b9d546 /media-sound/pamix/pamix-1.6-r3.ebuild
parentb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (diff)
gentoo auto-resync : 29:05:2023 - 15:17:30
Diffstat (limited to 'media-sound/pamix/pamix-1.6-r3.ebuild')
-rw-r--r--media-sound/pamix/pamix-1.6-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/pamix/pamix-1.6-r3.ebuild b/media-sound/pamix/pamix-1.6-r3.ebuild
new file mode 100644
index 000000000000..72606c883207
--- /dev/null
+++ b/media-sound/pamix/pamix-1.6-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/patroclos/PAmix.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+DESCRIPTION="PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+unicode"
+
+RDEPEND="
+ media-libs/libpulse
+ sys-libs/ncurses:=[unicode(+)?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ncurses_pkgconfig.patch"
+ "${FILESDIR}/${P}-xdgconfigdir.patch"
+ "${FILESDIR}/${P}-fix-output-scrolling.patch"
+ "${FILESDIR}/${P}-fix-ncurses-freezing.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ if [[ ${PV} != 9999 ]] ; then
+ sed -e "/^include(CMakeGitDefines.cmake)/d" -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_UNICODE="$(usex unicode)"
+ )
+ [[ ${PV} != 9999 ]] && mycmakeargs+=( -DGIT_VERSION=${PV} )
+ cmake_src_configure
+}