summaryrefslogtreecommitdiff
path: root/media-sound/paprefs/paprefs-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /media-sound/paprefs/paprefs-1.1-r1.ebuild
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'media-sound/paprefs/paprefs-1.1-r1.ebuild')
-rw-r--r--media-sound/paprefs/paprefs-1.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/paprefs/paprefs-1.1-r1.ebuild b/media-sound/paprefs/paprefs-1.1-r1.ebuild
new file mode 100644
index 000000000000..fcf064732a0d
--- /dev/null
+++ b/media-sound/paprefs/paprefs-1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic meson xdg-utils
+
+DESCRIPTION="PulseAudio Preferences, configuration dialog for PulseAudio"
+HOMEPAGE="https://freedesktop.org/software/pulseaudio/paprefs"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+RDEPEND="dev-cpp/atkmm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ >=dev-libs/libsigc++-2.2:2
+ >=media-sound/pulseaudio-12.0-r1[glib]
+ x11-libs/gtk+:3
+ || (
+ x11-themes/tango-icon-theme
+ x11-themes/adwaita-icon-theme
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cxxflags -std=c++11 #568590
+ local mymesonargs=(
+ -Dlynx=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}